MHGH28-XTC - Unable to update to 2.9.1000 from 2.7.0

Hello all,

I have 4 of the MHGH28-XTC cards but I am unable to upgrade the firmware on one of them to 2.9.1000.

I get this error when I try to burn the firmware:

-E- Image burn Failed: Flash access failed: Flash write of 4096 bytes to address physical 0x10 failed: MFE_VERIFY_ERROR

I am wondering if the flash is damaged or corrupted on the card.

I’ve attached the command line prompts I used and card’s info to the post.

info.txt.zip (394 Bytes)

firmware_fail.txt.zip (1.1 KB)

I’ve tried using command prompt with Admin Mode but the same error occurs. Appreciate the suggestion thou.

No worries. One of the more Win experienced guys might be able to help better.

If nothing else seems to work, what are your Linux (CentOS or RHEL) skills like?

I can give you step by step exact cut-n-paste instructions for that to query things and then try stuff out.

Would probably take a bunch of back-n-forth, but is workable.

Looking at the firmware_fail.txt file, it seems to be complaining about write access to the flash.

Is there any chance it’s something simple like not running the command from an Admin mode command shell?

Note, I’m a RHEL/CentOS/etc type of Linux guy, not so much of a Win guy these days, so my Win knowledge isn’t very high.

if you are not, try using the latest MFT package (burning tools) Mellanox Technologies http://www.mellanox.com/page/management_tools

For windows look for 3.0.0