MIPI CSI-2 Camera not creating a video node. I2C works well and programs the camera

Hello there;

I have an OV9284 sensor. It is very similar to OV9281, in fact when I read the ID registers I get 9281. This sensor is on a custom board which is then connected to the AGX XAVIER camera input. I know the I2C works because when I run i2cdetect command I can see my I2C and I have used a Python script (smbus library) to write and read the camera’s registers. I can see that my camera is streaming and sending MIPI signals over but on the XAVIER I can not detect the camera. When I run any v4l2 command or any gstreamer command, it says no camera was found. When I do ls /dev/video*, again it tells me No such file or directory. I am fairly new to all of this so I am not sure where to go from here.

Any help is appreciated.

Did you integrate the driver and device tree?


I don’t believe so. I am going to read this link you sent me and find out how to integrate the driver and device tree and will get back to you.

By integrating the driver do you mean the V4L2 driver? Should I refer to the “V4L2 Kernel Driver (Version 2.0)” section of the link you sent me? I am very new to all of this so this is a little difficult for me to understand.

Yes, v4l2 sensor driver.
I would suggest to consult with vendor if have the driver would be easier.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.