Missing bin folder in cuda

Hello.

Kind of a newbee question. I’m working on a Jetson Xavier and I have installed all its environment using the SDK Manager (including CUDA). I have noticed that there is a cuda folder at /usr/local/cuda/ but with no bin folder in it… Moreover, I have installed jtop tool and in the INFO section, CUDA Libraries is ‘NOT_INSTALLED’…

I wonder if this is normal or if my cuda/nvidia environment is broken. I am working with deepstream doing camera pipelines

Thanks!

Hi,

Which JetPack version do you use?
We can find the bin/library folder in our environment.

$ ls /usr/local/cuda-11.4/
DOCS  EULA.txt  README  bin  compute-sanitizer  extras  include  lib64  nvml  nvvm  samples  share  targets  tools  version.json

Thanks.

I believe it is JetPack 4.6 [L4T 32.6.1].

$ cat /etc/nv_tegra_release
# R32 (release), REVISION: 6.1, GCID: 27863751, BOARD: t186ref, EABI: aarch64, DATE: Mon Jul 26 19:36:31 UTC 2021

$ ls /usr/local/cuda-10.2/
include  lib64  targets

While in my laptop I got

$ls /usr/local/cuda-11.8/
bin                EULA.txt  lib64             nvvm    targets
compute-sanitizer  extras    libnvvp           README  tools
doc                gds       nsightee_plugins  share   version.json
DOCS               include   nvml              src

Hi,

The same is with Jet-Pack version 5.0.2-b231 run-time installation.
I’ve tried to install the Non-runtime (debug - ? Not said actually) option multiple times without any success.
Maybe the Non-runtime installation installs the bin library?

Regards,
Zafrir

Hi,

Could you share more information about how you install the CUDA?
Thanks.

With the SDK Manager

As someone else said, with the SDK Manager

Hi, both

Please try to reinstall the CUDA packages with following command:

$ sudo apt install nvidia-cuda*

Thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.