Missing file libpython3.7m.so.1.0

IsaacGymEnvs used to work on my computer, Ubuntu 20.04, RTX 2070.
Now I get the following error message:

/home/karl/miniconda3/envs/rlgpu/bin/python3.7 /home/karl/reps/IsaacGymEnvs/isaacgymenvs/train.py
Importing module ‘gym_37’ (/home/karl/apps/IsaacGym_Preview_4_Package/isaacgym/python/isaacgym/_bindings/linux-x86_64/gym_37.so)
Traceback (most recent call last):
File “/home/karl/reps/IsaacGymEnvs/isaacgymenvs/train.py”, line 33, in
import isaacgym
File “/home/karl/apps/IsaacGym_Preview_4_Package/isaacgym/python/isaacgym/init.py”, line 5, in
from isaacgym import gymapi
File “/home/karl/apps/IsaacGym_Preview_4_Package/isaacgym/python/isaacgym/gymapi.py”, line 104, in
File “/home/karl/apps/IsaacGym_Preview_4_Package/isaacgym/python/isaacgym/gymapi.py”, line 63, in _import_active_version
module = importlib.import_module(package_path)
File “/home/karl/miniconda3/envs/rlgpu/lib/python3.7/importlib/init.py”, line 127, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
ImportError: libpython3.7m.so.1.0: cannot open shared object file: No such file or directory

Process finished with exit code 1

There is no file libpython3.7m.so.1.0 in the _bindings directory, but there is a libpython3.6m.so.1.0. It looks like IsaacGymEnvs had the ability use the 3.6 version instead but now has lost it. There is still no 3.7 version of the file in the Isaac Gym download. Is it possible to make it use the 3.6 version again?

This may be unrelated, but it stopped working when I tried to open IsaacGymEnvs as a Pycharm project. Previously, it worked when running in the terminal. Now the same error appears both in the terminal and Pycharm. Grateful for any help.

Did you try setting the LD_LIBRARY_PATH variable according to the installation documentation?

1 Like

Well, after your suggestion I did that, and now it works. Thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.