mount error: cifs filesystem not supported by the system

Hello guys

I am facing a problem trying to mount a cifs share and using the mellanox drivers because of the infiniband cards that I have. Then when I try to mount the cifs share with the command below I get that error shown below:

mount -vvvvvvv -t cifs -o username=user,password=password,vers=2.0 ///user /media/tmp

mount.cifs kernel mount options: ip=,unc=\\user,vers=2.0,user=soportemodemat,pass=**********

mount error: cifs filesystem not supported by the system

mount error(19): No such device

Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg)

I have tried with versions 1.0 and 3.0 too but I got the same error. I can provide the next information for you to give any idea to solve this issue please:

cat /etc/redhat-release

CentOS Linux release 8.4.2105

uname -r

4.18.0-305.17.1.el8_4.x86_64

modinfo cifs

filename: /lib/modules/4.18.0-305.17.1.el8_4.x86_64/weak-updates/mlnx-ofa_kernel/fs/cifs/cifs.ko

version: 2.31

license: Dual BSD/GPL

description: cifs dummy kernel module

author: Mohammad Kabat

rhelversion: 8.4

srcversion: 01E451882B55F354B7F130B

depends: mlx_compat

name: cifs

vermagic: 4.18.0-305.el8.x86_64 SMP mod_unload modversions

sig_id: PKCS#7

signer: Mellanox Technologies signing key

sig_key: BA:B0:F5:CD:23:24:A0:

lsmod | grep cifs

cifs 16384 0

mlx_compat 16384 13 rdma_cm,ib_ipoib,cifs,mlxdevm,iw_cm,auxiliary,ib_umad,ib_core,rdma_ucm,ib_uverbs,mlx5_ib,ib_cm,mlx5_core

grep -c cifs /proc/filesystems

0

Thank you in advance for your reply and any ideas are welcome.

Hello,

In RH8.4 it was added that CIF is depend on IB driver.

When MLNX_OFED is installed, it replaces IB driver implementation, thus original CIF kernel module that depends on it cannot function.

As a result, we replace it with dummy module, basically removing CIF support.

In MLNX_OFED 5.5 we added a small fix to prevent from error display upon CIF loading, but still CIFS will not function.

In order to work with CIF and our driver:

  1. You can either use inbox driver that comes with RH8.4 and thus no need in MLNX_OFED.

  2. Or, recompile CIF module manually after install of MLNX_OFED.

Best Regards,

Viki

Hi Viky.

Thank you for your reply.

I need the MLNX_OFED for the infiniband network card works properly. So could you tell me how can I recompile CIF module manually with the MLNX_OFED that is already installed.