MSI GV72-7RD (GeForce® GTX 1050). Issues with multiple applications after switch OS to Linux

Previously OS Windows 10 (with latest updates) and VMs (Ubuntu, Kali, Manjaro) via VMWare Workstation worked without any issues on this laptop.
Month ago I’d switched initially to Ubuntu(22.04 and 20.04), tried also Kubuntu and Manjaro with different desktops as well latest official download of Fedora - problem was occurred in all these cases. Checked with memtest - no problems find. Currently stopped with latest Linux Mint (because of “easy” GUI NVIDIA driver switch application) and tried several of them without successful result.

nvidia-bug-report for 30th of August (also have previous version for 28th of August, maybe some different information could be useful)

nvidia-bug-report_20220830.log.gz (278.4 KB)

Problem “description”

  1. Main (and most annoying) case: crashes of browsers/browsers tabs. Google Chrome - “too often”, but what can notice - it depends on tab. So, same URL, if tab restored - can crash again, if opened in new tab - “could survive”. If start Chrome task manager - after “some time” (1-5-10 minutes) browser “silently closed”.
    For FF tabs and browser in general could crash but less often (same “subjectively observed” frequency), but all times it is possible to restart tab/browser.
    For Chrome it occurs even in default state, when app is just installed and try to connect google account sync.
    Had try for both browsers to use “no script” extensions - not solved.
  2. Obsidian notebook app image - rare “app freeze” (easy to close and restart, usually without data loss)
  3. VS Code - “silent” app close in random times. Couldn’t find dependency.
  4. Slack (snap version) “freeze”.

Some other applications (Youtube music desktop (also snap), PyCharm, xed text editor) are working without any issues.
When tried “default” Manjaro and Ubuntu 22.04 installations - “random close” happen with telegram desktop. For current configuration, I didn’t notice about crashes with it (at least last week) - and it is also “snap” (if it could somehow be useful).

“Just guess”, that I decided wrong version of drivers or missed/didn’t configure something correctly, related to video drivers. Will be grateful for suggestions how to investigate/understand/fix this. Thanks!

nvidia-bug-reports for 28th of August (maybe some different information could be useful)

nvidia-bug-report_20220828.log.gz (275.8 KB)

You’re in offload mode, i.e. the nvidia gpu isn’t used at all unless you explicitly set some application to run on it.
There was only one segfault from chrome in the logs

ThreadPoolForeg[4463]: segfault at 2a71fffc000a ip 00005596bd08282e sp 00007f91ecabdcb0 error 4
chrome[4173]: segfault at ffffffffffffffff ip 00005596bc3e38c2 sp 00007ffe5b071530 error 7 in chrome[5596bc351000+97f8000]
chrome[3938]: segfault at ffffffffffffffff ip 00005596bc3e38c2 sp 00007ffe5b070ee0 error 7 in chrome[5596bc351000+97f8000]

which also doesn’t seem to be graphics related but rather memory.
Please check your system memory.

Thank you @generix for an answer!
Sorry for a such “newbie” question: can I turn off offload mode somehow? Thanks!

On most ubuntu based distros you can use
sudo prime-select nvidia
and reboot to always run everything on the nvidia gpu.
Possible modes are: intel, nvidia, on-demand

Hi, thank you @generix one more time :)
Yep, I had try to use nvidia mode - unfortunately, it is not solving the problem. Somehow more stable (obviously much better than intel mode which is completely disaster :)), but same issues.
I had try one more Linux distro (Endeavour OS) and it has nice logs-collection tool with interesting (for newbies like me :)) tutorial about setup NVIDIA drivers. However, this tutorial makes me “somehow more confused” and this is where: I have nVidia GP107M [GeForce GTX 1050 Mobile] card. But is it “optimus” class or not? What flavor of driver expected to be most suitable?

Sorry for so many questions and thanks! :)

P.S. Latest logs from mentioned logs tool, if it could be useful:

You still get a lot of graphics-unrelated crashes, please check your hardware, especially system memory.

Thanks! I’d run this test (from MX Linux Live CD, last version) this weekend, all 4 were passed with 0 errors. Maybe there is some “better version” of such tests?