Mst sdk api

Where can I find the API for the mst package (mtcr library)?
I’m fine if you will point me the git project for mst tools like i2c

Hello @dimax.main,

You can refer to the official GitHub repository of the mstflint project, the mstflint project provides tools and libraries for managing and configuring Mellanox devices, including the mst package.

You can find the mstflint project on GitHub using the following link:

Hope this answers your question.


It helped a bit but it has nothing about the mtusb device or i2c access.

Anyway I managed to build my application using WinMFT SDK.
But I still have an issue with opening a mtusb device, although I know that device is connected and mst status can see it:
My application name is sprutm. I placed it into the WinMFT folder. I run command shell as Administrator:

What do you think can be an issue?
I believe it is something with security on Windows.
Let me know if you need more details.
Thanks. Regards.

Any updates here? We can not move forward with our development without your help.

App refers to the device linux path.

Try only mtusb-1 without /dev/mst.

Thanks but it does not help. From what I can see both ways are supported but for none works:

Because I still can’t find any reference on how to use MFT package with mtusb-1 I’m not sure that below code is correct:

    /* Open device */
    mf = mopen( config.mdev );
    if( !mf )
        failed( errno, "Can't open %s : %s", config.mdev, strerror(errno) );

Also it is strange that errno is not set.

Can you please scan the mtusb device?

mlxi2c -d <mtusb_dev> scan

Hi. I run it with MTUSB-1 connected to USB but not connected to the Mellanox board.

But I do not understand how it can help.
My issue is not on i2c side. I can not open mtusb device with mopen. mopen fails without errno update but returns a zero file descriptor.