Hello, How to get device entry in /dev ? I have installed MCX353A-FCBS into my VMware ESX server. I see it as ethernet 40G adatper.

I have installed MFT tools:


but I don’ t have any mellanox device in /dev directory. Neither /dev/mst/* or anything similar.

I have already tried different ESX versions 6.5 U1, 6.7.0, 6.7.0 U1. Also tried to install original Mellanox drivers instead of ones included in ESX. Stil problem is the same - there is dev entry.

Otherwise /opt/mellanox/bin/mst status shows device

MST devices:




[root@esx1:/opt/mellanox/bin] ./mlxfwmanager

Querying Mellanox devices firmware …

Device #1:

Device Type: ConnectX3

Part Number: MCX353A-FCB_A2-A5

Description: ConnectX-3 VPI adapter card; single-port QSFP; FDR IB (56Gb/s) and 40GigE; PCIe3.0 x8 8GT/s; RoHS R6

PSID: MT_1100120019

PCI Device Name: mt4099_pci_cr0

Port1 MAC: f45214f67850

Port2 MAC: f45214f67851

Versions: Current Available

FW 2.32.5100 N/A

PXE 3.4.0306 N/A

Status: No matching image found

Hello Rihards,

You can see the device with:

esxcli network nic list


lspci -v | grep Mellanox


mst status -v

But the device is not listed under /dev and ESXi doesn’t have /sys.

Is there something you are trying to do? What are you looking for?

Many thanks,