Multi streaming resulted to accuracy drop

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) Orin
• DeepStream Version 6.2
I have a built deepstream pipeline which was initially designed to accept one input source and the pipeline worked well. However when i changed the pipeline to accept several inputs there was a noticed accuracy loss in the classification. Is this expected? if not Does this mean that the issue is with the used classification model or the way nvstreammux is used in the code?
Configuration files batch size were modified to match number of input sources.

can you please advise?

Seems not.

Not sure. Can you provide the way to reproduce the issue?

can i send the code through messages as it’s not an open source yet?

Sure. Please.

file is shared for you support please

can you please update

@axnet

The sample deepstream_python_apps/apps/deepstream-test3 at master · NVIDIA-AI-IOT/deepstream_python_apps (github.com) is for multiple input streams, and it also supports single input stream.

  1. You don’t need to use two python apps to run multiple streams case and single stream case.
  2. I compared the python code in the two folders and notice that you set the nvstreammux “width” and “height” as 1280x720 in single stream app while 640x640 in multiple streams app. They should be set to both 1920x1080 for your test video resolution is 1920x1080.

Once i set 1920x1080 in multi the terminal process all frames and then lags which will not allow the video to be saved or opened to check if this what causing the issue

Can you explain what does this mean? What is “the terminal”? Who “lags”? Why the video could not be saved or opened?

The original topic is about accuracy, is this another issue?

when running the python code file in linux command terminal with the “1920x1080” modification in the code it gets stuck and doesn’t process all frames.
I can only view the ouput once all frames are processed.
No this is not a different topic but the suggested solution caused another issue

any update?

You have sent two apps to us, and I’ve pointed out the different between the two apps. It is no use to compare the outputs from two apps with different configurations.

I’ve tried the app in “Multi” folder. It has some error in the code. After fix the errors. I tried single input and 4 inputs with the same app. No accuracy drop found.

I’ve tried modifying the “width” and “height” of nvstreammux to 1920x1080. No issue happens.

Have you used the Multi folder for both, single and multi input? can you please share with me through the messages the modified copy of the code. As i wasn’t able to modify the 1920x1080 and run the app successfully

Yes. Use the same app with single and multi inputs.

Thank you for sharing, but the same issue is there running the app will run to frame 670 then it will lag and stop running at frame 670 which will not make the output to visible since all frames has to be processed for the output to be saved to “output” folder
image

please support

and when increasing input sources to 8, batch size = 8 it stops at frame = 43.

I don’t reproduce the “stop” with your code. Do you change anything?