Get stuck in the running deepstream python apps with more than one rtsp streams

• Hardware Platform (Jetson / GPU) : Jetson Xavier nx
• DeepStream Version : 5.0 DP/GA
• JetPack Version (valid for Jetson only) : 4.4 Developer kit
• TensorRT Version : 7.1.X

Hi guys,
I run both apps of the deepstream-python-apps, deepstream-imagedata-multistream and deepstream-test3. These apps work correctly for multi file sources but for multi rtsp source get stuck in inference processing and the performance is dropped under 1 FPS for 2 RTSP streams. and also there is another problem is that when I want to enable showing the results in screen, only the first screen is showed, but the second show of stream is black and doesn’t show any result for that stream.

How I can to solve the problem for multi-stream rtsp?

Note that when I run the each of stream individually in the separate command windows, It’s work. Why does this problem occur?

This problem is’t a bug, because I used one stream and then repeat this stream N times. The reason of problem can be likely the name of rtsp were same. but for file sources it’s correctly work if the name of [uri]s be same.

For the python apps we run with this command:

python3 python_app_file [uri1] [uri2] … [uriN]

for files the <uri1, [uri2] … [uriN] can be same but for rtsp it’s not correct to be same.

For the deepstream sdk in the config file we have to define for rtsp:

num-streams = 1
uri = rtsp1

num-streams = 1

For the deepstream sdk in the config file we can to define for file:

num-streams = N
uri = file