Ncu-ui is not working

Hello. I have a problem.
I made 18GB size ncu-rep report file using ncu profiler.
When the gui window opened, the message "loading ncu-rep file " printed below.
… And then a few seconds later, the window automatically closed.
There is no output error log on my terminal.

What should I do?

If you want additional information, I’ll update it.

** Nsight Compute Version: 2023.2.2.0(build 33188574)

Thanks

Hi, @hnts03

Can you try going to Options->Profile->Report Source Page->Delay Load ‘Source Page’, set it to “Yes” to see if any improvement ?

If still not work, you can try with 1. Customization Guide — NsightCompute 12.4 documentation to get info from report.

Hi @veraj , Thanks for reply.
I tried your solution(Delay Load ‘Source’ Page – Yes) but it still not working :p

Is there any way to open this report file in GUI?
I’m so sorry but I want to manage data in the Graphic interface.

Hi, @hnts03

It should work if your machine has enough RAM to hold the full report in memory. With an 18GB report, you would probably need 64+GB free host memory and wait an hour or so to load.
The application closing is the init system/kernel killing the process because it’s OOM’ing.
This would be logged in the output for dmesg or journalctl -k.

You’d better filter during collection to obtain a targeted report, or load it via the CLI or Python Report Interface for automated analysis.

Hi, @veraj

Thanks for your help.
I’ll change the HW settings :)

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.