Nsight compute CouldNotOpenFIle error


I have the following error.
I got .ncu-rep file on linux(cuda 11.3.1/A10 GPU) and I wanted to open that file on Window host, but I got Failed to Load error. I’m using Nsight compute 2021.1 version.
I used [ ncu -o filename python filename.py ] command.

Doesn’t Nsight compute support A10 GPU? I can only see A100 GPU supported by Nsight Compute on overview page( NVIDIA Nsight Compute - 2021.1 | NVIDIA Developer ). so I thought it was a problem about version or GPU but I can see the output on cli when I don’t use [-o] option.

In addition, I can open the nsys-rep file on Nsight systems with the same way.
Thank you so much.

compute error

Nsight Compute should work with an A10 GPU. It may be some sort of file corruption or permissions issue. Can you try reading it with the CLI on the original Linux machine with “ncu -i --page details” and see what comes out? And on Windows, in the install location you should find “ncu.bat”. Try the same command “ncu.bat -i --page details” on Windows and let me know what you see.

Thank you for your reply.

First, I tried "ncu -i --page details " on Linux. and the following error came up.

==ERROR== ‘details’ does not exist or is not an executable. Please make sure to specify the absolute path to ‘details’ if the executable is not in the local directory.

but, It works when I use “ncu -i test1.ncu-rep --page details” I can see the following result. and i can’t still open this file on Window host Nisght Compute


Second, I’m sorry but I don’t know how to find “ncu.bat” in the install location.
I can’t find ncu.bat in this directory.

and Do you mean trying “ncu.bat -i --page details python myfile.py” command on Window Host Nsight compute?
I didn’t connect Window Nsight Compute and linux server. because I’ll use Nsight on multi-node environment with slurm later and now I use proxy server. (I couldn’t use Nsight Systems with connecting Window host and Linux on this environment because of firewall problem ).
I just moved .ncu-rep file from linux to Window, and I tried to open the file. this is my way.
If I misunderstood what you said, please let me know.

and I’m wondering if Nsight compute Window host requires Nvidia display driver.

Thank you!

type or paste code here

I used Nsight systems on multi(2)-node slurm environment as I said. I wrote “srun nsys profile [options] python myfile.py” command line on the shell script. Then I could get the .nsys-rep file on the both node. and I can open that file.

now I tried to get .ncu-rep file the same way, but I got the file only on the master node. and this file still can’t be open in Window Host Nsight Compute. I don’t know where the cause of the problem is…

ncu.bat is a few levels up on Windows. I think it is on your machine at “C:\Program Files\NVIDIA Corporation\Nsight Compute 2021.1.1\ncu.bat” . Can you try using that ncu.bat from the shell on windows with the command “ncu.bat -i test1.ncu-rep --page details”.

Also run “ncu.bat -v” on Windows then “ncu -v” on the Linux machine where you ran the profile and share the results so we can check if there is any version mismatch.

I can see these files at “C:\Program Files\NVIDIA Corporation\Nsight Compute 2021.1.1”

and when I run “ncu.bat-v” on Windows CMD, it says,

NVIDIA (R) Nsight Compute Command Line Profiler
Copyright (c) 2018-2021 NVIDIA Corporation
Version 2021.1.1.0 (build 29918364) (public-release)

and when i run “ncu-v” on linux I can see the same result above. I already checked the version.

Also, I can see the following results when i tried “ncu.bat -i test1.ncu-rep --page details” on Windows cmd

I think it is a problem about Windows Nisght computer. I can open test1.ncu-rep file on Linux host of other machine. but i still need to use Windows host on my machine.

Can you open the test1.ncu-rep file in the GUI on Windows? If so, the issue seems to be specific to the false1step.ncu-rep file. What happens when you run the command “ncu.bat -i false1step.ncu-rep --page details” from the Windows command line? If that seems to work, we can narrow it down to something about opening that file in the GUI on Windows.

I can’t open any ncu-rep file in the GUI on Windows. The same error(couldnotopenfile) come up

and when i run “ncu.bat -i false1step.ncu-rep --page details” from the Windows command line, i can see the result like below.

thank you

This is strange. I don’t know exactly why this would occur. It’s basically an error thrown when an fstream constructor fails. Were you able to move the file to a path that only had simple characters and no spaces and read permissions? For example, can you share the error message from the GUI when you move and open the file from “C:/Users/parlab1/Desktop/<file.ncu-rep>” ?

oh… I moved it and i can open it. I missed the most important thing. I spent a whole week soving this problem… ;_; thank you so much :)
(but I don’t know why Nsight Systems can open that files in the path that had spaces and korean.)

I’m glad we were able to find a workaround. We have a bug filed and hopefully this will be fixed in an upcoming release.

1 Like