How to profile remotely (QNX)?

As the description suggested, Nsight should be able to profile CUDA program remotely.

I’m trying to profile CUDA on QNX system, the Window version of Nsight compute doesn’t have QNX target option for some reason even though the picture on the webpage has, and I can’t even find the GUI executable on Linux version if there’s one.

The documentation suggested launch-and-attach command but without an executable the nv-nsight-cu-cli won’t launch.

Could anyone provide an example of using Nsight for remote profiling? Thank you!

Remote profiling on QNX is only available from Linux x86_64 hosts, please see the Platform Support release notes for details: https://docs.nvidia.com/nsight-compute/ReleaseNotes/index.html#support

In the Linux x86_64 version of Nsight Compute, the UI executable is called nv-nsight-cu and is located within the host/linux-desktop-glibc_2_11_3-x64 directory of you installation. There is also a script with the same name directly in the installation directory. See https://docs.nvidia.com/nsight-compute/NsightCompute/index.html#quick-start for details on this topic.

The documentation suggested launch-and-attach command but without an executable the nv-nsight-cu-cli won’t launch.
Could you please clarify what executable you are referring to, here?

Thanks for the reply.
Could you give some direction on how to profile QNX (Xavier Drive) platform program?
I tried

nv-nsight-cu-cli --hostname root@10.160... --mode=attach

when running the program on QNX and I got ==ERROR== No processes found on device.

Thanks!

The recommended workflow is to remote-launch the application on QNX from the Nsight Compute UI on the Linux x86 host. Select QNX as the target platform and then Remote Launch.

If you want to profile directly using the command line on the QNX system, you don’t need to specify --hostname or --mode attach. If you want to only launch on the QNX system but attach from the host, you need to use --mode launch on the QNX system.

Thanks for the reply.
I tired the standalone Nsight Compute and there is no QNX target available, only Linux and Windows.
In the release note it specified that QNX can only targeted by Linux x86_64 Drive SDK so I install the DRIVE Software 8.0, but it only includes Nsight System, no Nsight Compute.
Please let me know how can I get the correct version I need.
Thanks!

You have to run the Nsight Compute UI on the Linux host (is it not installed on the host)?

When you select the QNX target and Remote Launch, it will copy the necessary files (including nv-nsight-cu-cli) to the QNX target. (don’t expect to find nv-nsight-cu-cli on the QNX target until this time)

Hopefully, that was the problem. If not, write back.

Yes I was using Linux host, I tried on Ubuntu16 and Ubuntu18,
the 2019.1 version from this page: https://developer.nvidia.com/gameworksdownload#?dn=nsight-compute-2019-1 doesn’t have QNX target available (only showed Linux and Windows),
the Drive SDK from this page: https://developer.nvidia.com/drive/downloads doesn’t include Nsight Compute (the Nsight system can be use to profile QNX though).
Am I missing something here?
Thanks

I am also trying to do the same thing. I have the same issue as Matthew with not seeing a QNX option. Is there a better way to try to profile an application? I have tried using Nsight Eclipse Edition as well and am also having issues.

I opened the nv-nsight-cu. Still it doesn’t have qnx as an option. :(