Installation problem

I installed nsight compute on linux using the run file but it doesn’t seem to work. There is no gui app and the commands are unknown in the command line. Does anybody have any
suggestions? Don’t know if it helps but I kept the default directory for the installation.

Could you please describe in more detail what you tried, which commands would not work, and what is the output you are seeing? You should be able to find the GUI app


in the Linux installation directory within the


sub-directory. There is also a batch script directly in the installation root directory, which points to this executable. More details about using the GUI app can be found in the documentation:

I guess I’m too used to Windows. All I had to do is run the script from the folder. I thought I would be able to run it from anywhere like any other command.
Thank you for your time.

No, you are correct, you should have been able to run that from any directory. It’s a known issue that will be fixed in the next update. Note that you can run the actual executable within the “host” directory (i.e. not the script) from any directory.

When I run nv-sight-cu it tells me that the command was not found. In my NVIDIA-Nsight-Compute-1.0 I have both nv-sight-cu and nv-sight-cu-cli. These are the ones I tried to run. I think these two are the same as the ones in the host/linux-desktop-glibc_2_11_3-x64 folder. Could it be because I need root petmision to run them? I tried with sudo from outside the folder but they still seem to be unknown.

As far as I know, root permission should not been required to run nv-nsight-cu.
Could you give me more details what you tried, which path to execute command?