need some help setting up cuda

How can i set up CUDA, to use in device emulation mode on a windows based box with no CUDA capable device.

I tried installing CUDA toolkit but it came out saying that no CUDA driver, which i can;t install since i have no CUDA capable device.
I needed this setup CUDA to (atleast debug) on my notebook, any help/suggestions for is greatly appreciated.

thanks in advance.

peace

You need these main steps to run CUDA using emulation mode on windows:

  1. Install CUDA toolkit

  2. Install CUDA SDK

  3. Install Visual Studio 2005 Express or Full edition( I didn’t try Visual Studio 2008 )

  4. Add cuda/bin in the path env variable

  5. make sure you have these environment variables based on your installation directories

CUDA_BIN_PATH: i.e. C:\CUDA\bin

CUDA_COMMON_INC_PATH: i.e. C:\Program Files\NVIDIA Corporation\NVIDIA CUDA SDK\common\inc

CUDA_COMMON_LIB_PATH: i.e. C:\Program Files\NVIDIA Corporation\NVIDIA CUDA SDK\common\lib

CUDA_INC_PATH: i.e. C:\CUDA\include

CUDA_LIB_PATH: i.e. C:\CUDA\lib

NVSDKCUDA_ROOT: i.e. C:\Program Files\NVIDIA Corporation\NVIDIA CUDA SDK

  1. Install CUDA_VS2005 plugin to Integrate CUDA with Visual C++

http://forums.nvidia.com/index.php?showtopic=65111

http://sarathc.wordpress.com/2008/09/26/ho…-with-visual-c/

  1. Enable Syntax Highlighting for CUDA in Visual Studio

http://sarathc.wordpress.com/2008/09/04/ho…al-studio-2005/

The other thing, when you try to run your code make sure you are using Emudebug if you do the integration using CUDA_VS2005 plugin.

I hope that helps!

–OA

thanks a lot OA…that did the trick…

it helped a lot… :shifty:

Hello,

I downloaded and installed everything, but the folder (NVIDIA CUDA SDK) does not and instead I get this folder, I get “NVIDIA GPU Computing SDK Browser”

Who can help me further or give a link where everything is explained step by step???

I need it urgently …

Merci :)

I am a beginner, but my guess is that the folder name changes with the CUDA SDK version you install. That should not have any problems.