New XBox One/X gamepad will not remain connected with Jetpack 4.4

I tried connecting my new XBox One/X with Jetpack 4.4 today both using the Desktop and CLI and there is a problem.

I was able to pair the XBox One/X using both the Desktop and CLI, but the connection kept going from “connected” to “not connected”. I even updated/upgraded Jetpack 4.4, but still no joy.

However, my trusty XBox One connects just fine once it is paired.

Yes, I did permanently turn off Ertm, but to no avail when attempting to pair/connect the XBox One/X to Jetpack 4.4.

My XBox One/X pairs/connects just fine with my HP Laptop running Windows 10.

I think the problem with connecting the XBox One/X to Jetpack 4.4 is that the XBox One/X, unlike the XBox One, is sending its battery voltage status back to the OS (Ubuntu 18.04) after connection and the OS does not like it and disconnects.

Comments?

TCIII

Hi,
What interface is that gamepad using? bluetooth?

@WayneWWW

Bluetooth

TCIII

Do you connect it to other x86 ubuntu host before?

@WayneWWW,

I don’t run Ubuntu on any X86 machines.

This was the first time I had attempted to pair and connect the XBox One/X to any host.

TCIII

Hi TCIII,

We can only suggest to run the test with x86 ubuntu host to see if it’s Ubuntu 18.04 issue.