NGC enabled PC and Jetson

Hello.
I bought PC whose environment is setted as Ubuntu 16.04LTS + GPU driver + NVIDIA Docker(Docker CE).
I registered to NGC, get API key, pull docker image from NGC and confirmed following command work properly.
$sudo docker run --runtime=nvidia --rm nvcr.io/nvidia/cuda:9.0-cudnn7-devel-ubuntu16.04 nvidia-smi

But after setting up Jetson with this PC and having troubles regarding cuda, I found the nvidia-docker was lost.
I think I might have deleted it during trouble shooting of Jetson.

Then, it is OK to re-install nvidia-docker again following the instruction such as https://docs.nvidia.com/deeplearning/dgx/preparing-containers/index.html? I don’t want to lose Jetson’s setting up environment because I may want to
upgrade Jetpack later. Could you give me advices if there are checkpoints before starting installation of nvidia-docker?
Also, is it OK to install nvidia-docker2? Or do I have to install nvidia-docker1?

My PC environment is as follows.
Ubuntu 16.04LTS
GP102 [GeForce GTX 1080 Ti] (rev a1)
NVIDIA UNIX x86_64 Kernel Module 396.44

I look forward to hearing from you.

As far as I know, you should be able to have nvidia-docker (v1 or v2) installed on the same machine you use to install JetPack onto your Jetson with no problems.

NGC DL Framework containers work just fine with nvidia-docker2. The DGX installation page you cited mentions v1 simply because that’s the one that has shipped with DGX OS versions up to now. For non-DGX, you can just follow the instructions on the nvidia-docker GitHub page: https://github.com/NVIDIA/nvidia-docker/blob/master/README.md

Thank you for your advice.
I followed the instructions of https://github.com/NVIDIA/nvidia-docker/blob/master/README.md Ubuntu 14.04/16.04/18.04, Debian Jessie/Stretch. But following error came at $sudo apt-get install -y nvidia-docker2.

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-docker2 : Depends: docker-ce (= 18.06.1~ce~3-0~ubuntu) but 18.03.1~ce-0~ubuntu is to be installed or
                           docker-ee (= 18.06.1~ee~3-0~ubuntu) but it is not installable
E: Unable to correct problems, you have held broken packages.

I’m not sure if this was the reason, but after adding to /etc/apt/sources.list

deb [arch=amd64] https://download.docker.com/linux/ubuntu xenial stable

(above line was commented out before)
I could successfully install nvidia-docker2.

Thank you.