docker-ce installing on TX2

I tried to install docker on TX2 following the official website https://docs.docker.com/install/linux/docker-ce/ubuntu/#install-docker-ce, but I run into an error.
Steps are shown blow:

1.Uninstall older versions:
sudo apt-get remove docker docker-engine docker.io containerd runc

2.SET UP THE REPOSITORY:
sudo apt-get update
sudo apt-get install
apt-transport-https
ca-certificates
curl
gnupg-agent
software-properties-common

curl -fsSL https://download.docker.com/linux/ubuntu/gpg | sudo apt-key add -

sudo add-apt-repository
“deb [arch=arm64] https://download.docker.com/linux/ubuntu
$(lsb_release -cs)
stable”

3.INSTALL DOCKER ENGINE - COMMUNITY:
sudo apt-get update

sudo apt-get install docker-ce docker-ce-cli containerd.io

RESULTS:
Job for docker.service failed because the control process exited with error code. See “systemctl status docker.service” and “journalctl -xe” for details.
invoke-rc.d: initscript docker, action “start” failed.
● docker.service - Docker Application Container Engine
Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
Active: activating (auto-restart) (Result: exit-code) since Mon 2019-07-29 21:24:24 CST; 11ms ago
Docs: https://docs.docker.com
Process: 9249 ExecStart=/usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock (code=exited, status=1/FAILURE)
Main PID: 9249 (code=exited, status=1/FAILURE)

Jul 29 21:24:24 tegra-ubuntu systemd[1]: Failed to start Docker Application Container Engine.
Jul 29 21:24:24 tegra-ubuntu systemd[1]: docker.service: Unit entered failed state.
Jul 29 21:24:24 tegra-ubuntu systemd[1]: docker.service: Failed with result ‘exit-code’.

QUESTIONS:
1.Directly: how to solve the problem above?
2.JetPack version: # R28 (release), REVISION: 1.0, GCID: 9436269, BOARD: t186ref, EABI: aarch64, DATE: Fri Jul 28 17:04:29 UTC 2017
How to get JetPack version with the format “JetPack d.d”
Any relations with the VERSION?
3.Is it necessary to upgrade JetPack to the latest version when develop with JETSON TX2?
I haven’t done that.

Hi 1101784344,

The NVIDIA docker support on Jetson platform from R32.2, please upgrade your system to the latest version through JetPack, you can find relevant information from: https://developer.nvidia.com/embedded/jetpack

Here is tutorial for your reference:
https://github.com/NVIDIA/nvidia-docker/wiki/NVIDIA-Container-Runtime-on-Jetson

Thanks

Hello, kayccc,

I have a trouble with LOGIN. After creating a NVIDIA account, I can now login from the web by my social account, but I can’t login by email and password. Meanwhile, the SDKMANEGER only has the way of email and password. So, I now can’t login the SDKMANEGER and thus I can’t move on. JetPack is not to be upgraded. Any solutions?

I have learned that JetPack4.2.1 itself include docker, but I have no idea what’s the difference between this “docker” and the one I mentioned before(https://docs.docker.com/install/linux/docker-ce/ubuntu/#install-docker-ce)? Are they compatible? What about so-called “nvidia-docker”? How can I distinguish and how do I choose to use them?

Another question, I have found methods of installing JetPack by .run file naming “JetPack-L4T-3.1-linux-x64.run”. Is it suitable for me, accounting for the docker support?

Thank you very much.

Hi 1101784344,

Please follow https://docs.nvidia.com/sdk-manager/install-with-sdkm-jetson/index.html to see if can resolve the installation issue.

Regarding the docker-ce, that should be for host PC, not for Tegra devices.