NIXOS 22.11 - RTX 4090 - Flickering on display port


When using windows 11, the 4090 seems to work properly on any port (both hdmi and DP). When booting on linux though, a strong and annoying flickering immediately starts. When the flickering starts to keep getting worse even across reboots. Even when switching back to Windows 11 and the only thing making it disappear again seems to be changing to another display port or doing a cold boot and stay on windows 11…
Any clues?

Please try a different cable.

Hi @generix, I would like to stress that on windows no such flickering occurs. I also tried an HDMI cable and the same thing was happening.
I would like to add that using PRIME reverse offload via the integrated graphics DP shows no issues (but suboptimal).

The linux driver has different thresholds, so a slightly bad cable/monitor might work on windows but not on linux.
Though now I don’t understand your issue at all
“Flickering on displayport”
“I also tried an HDMI cable”
How many monitors connected where?
Please run as root and attach the resulting nvidia-bug-report.log.gz file to your post.

@generix, very well, I will try a brand new DP cable and run

“Flickering on displayport”
“I also tried an HDMI cable”
How many monitors connected where?

One monitor, I simply tried different ports. The problem manifested always when connecting the monitor directly to the GPU.

@generix , I did as you requested:
nvidia-bug-report.log.gz (345.7 KB)

changing cable:
Problem still persisted. But I noticed something, the problem persisted even when I changed the mode back from “non PRIME/direct connection monitor and GPU” to “reverse PRIME” the flickering was still there. Switching on/off the screen didn’t do anything.

You don’t have any monitors connected to the nvidia gpu so it obviously can’t be the source of your issues.

You mean in the reverse PRIME? True, but at the same time I have my display manager running on the nvidia GPU, so there could still be issues in the way rendered stuff is sent to the integrated graphics if that makes sense? Obviously I don’t have any problems with the integrated graphics, and there’s no issue with the nvidia GPU on windows 11. Also the problem leaks for a bunch of minutes also to windows 11 after rebooting… so whatever is messing with the GPU or the monitor it seems to persist across OS resets…

Wait, I have run the nvidia-bug-report with the monitor connected on the integrated graphics. Give me a sec.

@generix Here is the report with the monitor plugged to the DP.
nvidia-bug-report.log.gz (424.0 KB)

I’m starting to think that this could be a screen problem? I thought I tested the HDMI separately but maybe I tested it once the system was already flickering and now I can see that the HDMI port does seeem to not be affected by the problem.

It is weird that his problem is triggered only via linux via display port. I don’t have an extra display port monitor to test. For now I will use the HDMI. It would be nice if we could understand why I can’t use the display port with this screen on linux but it’s totally fine on windows. Could it be a gsync issue or similar?

I noticed that when logging out, the flickering was still there but also the monitor had also some ghosting artifacts of the desktop wallpaper.

I played a bit more and I noticed something even weirder.
Situation 1:
KDE plasma, Wayland, logging-in after sddm with the DP connected to the monitor causes the issue to occur.
Situation 2:
KDE plasma, Wayland, logging-in after sddm with HDMI connected to the monitor: no issue. Switching to display port: no issue.

On KDE plasma, X11 this trick doesn’t work.

Since it flickers nevertheless it’s connected to the mainboard’s or the nvidia gpu’s displayport, I suspect this is some odd monitor issue. To check you could provoke the flicker with linux, reboot to windows so it still flickers, then disconnect power of the monitor, wait some time, then reconnect.
Checking with google, Dell released a firmware update for that monitor, please apply.

Upgrading the firmware solved the problem! Thank you for so much for helping me… in the end it wasn’t indeed an NVIDIA problem.