No display on 1440p Monitor after Driver Update

I’m a complete Linux newbie trying to get into…well, Linux. I’d get going but I keep getting stuck at this point. I update my graphics driver using YaST and after reboot my 1440p monitor no longer works. This is not exclusive to my current OS as I’ve tried Debian, Fedora, and Ubuntu and had the same outcome on all of them. Any help is greatly appreciated. I may need a little hand holding as I learn the ropes along the way.

System:
OpenSUSE 13.2 64bit
NVIDIA Driver: 340.76
GTX 780
1x X-Star 1440p monitor
2x Asus 1080p monitor

Note: I’ve googled this and tried a few things, but it seems all the ones where the problem gets fixed gets over my head and capacity on how to dig into the linux system. Please don’t think I didn’t try to fix the problem before heading here.

I also have a Korean Monitor (QNIX 1440p) which is the same as the X-Star but with a different name. You might have to provide your monitor with a custom EDID.

https://drive.google.com/file/d/0B6-Cduw95lY6c2U5c3F5VDQyNFE/view?usp=sharing

http://pastebin.com/cz9d3QJ1

Your connector (DFP-0) will probably be different. You’ll also have to configure your other display in your xorg.conf.

That’s what I was expecting, and typically what the resolution is. Can you walk me through the process on how to complete that, please.

The first thing to do would be look at your existing Xorg log to find out what’s wrong.

You’ll find the current log at /var/log/Xorg.0.log.

I have absolutely no experience with configuring multiple monitors in Xorg.
To find out what connector(s) your display(s) is(are) connected to start nvidia-settings “X Server Display Configuration”.

To use the EDID it’s best to put it into /etc/X11 and reference it with the right connector name, like in my xorg.conf.

Option “CustomEDID” “DFP-0:/etc/X11/monex.bin”

I’m actually not seeing /var/log/Xorg.0.log at all.

Don’t know what version of Xorg openSUSE ships (could be that it ships the version with the wrapper script for Xorg.bin) see how to view the log with journalctl and also read the part about Fedora 21.

Okay, and here is what we get:

http://pastebin.com/1VY1njVG
http://pastebin.com/Eus6VT0Q

I dug through it, but I’m not really sure exactly what I’m looking for or how to edit it.

But there is this:
"Feb 08 14:56:52 linux-dfrt gdm-Xorg-:0[1131]: (WW) NVIDIA(GPU-0): The EDID read for display device DFP-3 is invalid: the
Feb 08 14:56:52 linux-dfrt gdm-Xorg-:0[1131]: (WW) NVIDIA(GPU-0): checksum for EDID version 1 “extension is invalid.”

Whereas the other two read:

Feb 08 14:56:52 linux-dfrt gdm-Xorg-:0[1131]: (II) NVIDIA(GPU-0): Display (Ancor Communications Inc VE228 (DFP-0)) does not
Feb 08 14:56:52 linux-dfrt gdm-Xorg-:0[1131]: (II) NVIDIA(GPU-0): support NVIDIA 3D Vision stereo.
Feb 08 14:56:52 linux-dfrt gdm-Xorg-:0[1131]: (II) NVIDIA(GPU-0): Display (Ancor Communications Inc VE228 (D

So I’m pretty sure I’m in the wrong place, but that still seems like pertinent information for the display not working.

It would be better and more readable if you just redirect the output of the command into a file like “journalctl -whatever > yourfile.log”. It looks like you copied the output manually.

How does your current xorg.conf look like? I’d be surprised if you got the Korean monitor to work without setting a correct modeline. Otherwise without the correct EDID the NVIDIA driver usually tries to set it to 800x600 which doesn’t work on this monitor and results in a black or corrupted image.

How did you install the NVIDIA driver? Nouveau (the open source NVIDIA driver) is mentioned an aweful lot in your logs. A correct installation of the NVIDIA driver blacklists the nouveau module so that it isn’t loaded at boot. You should have some *.conf file in /etc/modprobe.d that contains “blacklist nouveau”.

Also you should figure out which output is connected to which monitor. You seem to use DFP-3 and DFP-0 for one monitor. As I said just start nvidia-settings and you should easily find that out.

I’ll create a new one for you this evening when I get home from work.

You are completely correct. After updating the driver the monitor turns on, but there’s no display and it shows 800x600.

I installed the driver using YaST with the Nvidia Repository.

I’m pretty sure it’s DFP-0, but again I’ll check when I get home. I tried (maybe on this install) to create a new monitor output to resolve the issue which is possibly why there’s DFP-3 and DFP-0.

If you’re seeing errors about the EDID checksum being invalid, it means the driver is rejecting it because if the checksum is wrong, it’s reasonable to assume that everything else in it is wrong too. The driver avoids using information from the EDID in that case on the off chance that it could be damaging to the monitor. If the monitor consistently provides the same broken EDID, then I would recommend contacting the monitor manufacturer or the retailer you purchased it from to see if they can provide a firmware update or a replacement with a fixed EDID.

If you want to try to work around the problem in the driver, you can set the IgnoreEDIDChecksum option to “DFP-3” in /etc/X11/xorg.conf. Please use this option at your own risk.

These monitors work with Windows without problems, but need a 1440p modeline or custom EDID for Xorg. Does that imply that it has a correct EDID, but can’t validate it on Linux? When I tried nouveau on my card and started weston from a TTY it launched in 1440p without any configuration as far as I can remember.

I would not expect any support from the retailer or manufacturer. The business model of these 1440p monitor manufacturers is to buy A- quality panels from Samsung and put a bezle around it and sell it for next to nothing. They don’t even have an english language website and for some reason sell the same monitor with different names (X-Star, QNIX, Monex). They are all made in the same factory.
https://www.youtube.com/watch?v=8Jr7zCIzi4s

So I guess the problem is either Xorg or the NVIDIA driver being to strict with the EDID, since it works with nouveau and wayland.

SOLUTION TO running 1440p korean monitors in linux

Had the same problem you have to make it ignore the EDID instructions are below, tested with ubuntu 14 and steam os note on steam os just paste the same xorg.conf in the correct location.

Monitor setup
For 1440p korean monitors you need to edit your xorg.conf
1.generate Xorg.con file with this command
sudo nvidia-xconfig
2.edit xorg.conf
sudo nano /etc/X11/Xorg.conf
3.enter this line under devices section
Option “IgnoreEDIDChecksum” “DFP”

Here’s a copy of my xorg.conf for you to check out

nvidia-xconfig: X configuration file generated by nvidia-xconfig

nvidia-xconfig: version 331.113 (buildmeister@swio-display-x64-rhel04-03) Mon Dec 1 21:15:34 PST 2014

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0”
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
EndSection

Section “Files”
EndSection

Section “InputDevice”
# generated from default
Identifier “Mouse0”
Driver “mouse”
Option “Protocol” “auto”
Option “Device” “/dev/psaux”
Option “Emulate3Buttons” “no”
Option “ZAxisMapping” “4 5”
EndSection

Section “InputDevice”
# generated from default
Identifier “Keyboard0”
Driver “kbd”
EndSection

Section “Monitor”
Identifier “Monitor0”
VendorName “Unknown”
ModelName “Unknown”
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option “DPMS”
EndSection

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
Option “IgnoreEDIDChecksum” “DFP”
EndSection

Section “Screen”
Identifier “Screen0”
Device “Device0”
Monitor “Monitor0”
DefaultDepth 24
SubSection “Display”
Depth 24
EndSubSection
EndSection


I have windows and am having the same problem after the last Nvidia Update and now a the latest windows update. How can I edit the files in windows? Thanks!