No element "nvinfer"

Hello,

I try to run script:

gst-launch-1.0 filesrc location=/opt/nvidia/deepstream/deepstream-4.0/samples/streams/sample_1080p_h264.mp4 ! \
            	decodebin ! m.sink_0 nvstreammux name=m batch-size=1 width=1280 \
            	height=720 ! nvinfer config-file-path=$1 ! \
            	nvvideoconvert ! nvdsosd ! nvegltransform ! nveglglessink sync=false

but I get error as below image:

How can I fix it?

Thanks!

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU)
• DeepStream Version
• JetPack Version (valid for Jetson only)
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

1 Like

Hello @Fiona.Chen,

I use Jetson TX2, jetpack 4.2
Deepstream 4.0
TensorRT 6.0.1

Thanks.

Can you run “gst-inspect-1.0 nvinfer”? What is the result?

Screenshot from 2021-02-22 08-52-35

Thanks

DeepStreamSDK is not installed correctly, please install deepstreamSDK correctly.

DeepStreamSDK 4.0 is not supported now. Please use latest deepstream. QuickStart Guide — DeepStream DeepStream Version: 5.0 documentation

Hi @Fiona.Chen,

because of some reason so I have to use DeepStream 4.0. In this case, I should reinstall DeepstreamSDK, right?

Thanks

Sure. And the related drivers also need to be correct.

@Fiona.Chen, thank you !

Hi @Fiona.Chen

I have reinstalled Deepstream 4.0 follow this link, but I still get the same error.

Do you have other ideal for it?

Thanks!

No. No idea.