No GPU option in Digits. Closed

Similar to issue

Building CUDA and cuNN without errors. Configured caffe makfiles for GPU, also without errors.

I built digits 6 as per

As in the issue above, I don’t have an option at the digits web frontend to use GPU to train a new model.

But, when I run


The GPU is properly detected:

`Device #0:

CUDA attributes:
name GeForce GTX 960M
totalGlobalMem 2100232192
clockRate 1176000
major 5
minor 0
NVML attributes:
Total memory 2002 MB
Used memory 1788 MB
Memory utilization 3%
GPU utilization 9%
Temperature 62 C

I debuged digits/model/tasks/ and displayed

config_value('caffe')['cuda_enabled'] = true
config_value('gpu_list') = 0

My apologies. This is a non issue. It’s true that I didn’t get an option to select a GPU like in the tutorial I was following, but in the end, it was using the GPU properly.

I just requested that the Model be trained, and the next screen showed all statistics including the Nvidia GPU.