No hardware acceleration on RTX3060 (Dell XPS 17 Laptop)

On a brand new Dell XPS 17 with Nvidia RTX3060 :
On a fresh install of linux Mint 20.2 (Cinnamon running kernel 5.4.0-74) followed by apt-get install update and upgrade I am welcomed by a “no hardware acceleration message”. Incidentally the sound output is a dummy one (I guess the HDMI module might have a connexion to my graphics problem??).
I installed the nvidia 470.63.01 driver and rebooted to a black screen.
I deactivated the secure boot in the BIOS and tried the two different fast boot options (minimal and thorough), without improvement.

TTY was accessible, I ran the bug reporter (see attach).

Could anyone tell me if OPTIMUS cards are at all supported on linux and if experience with this particular machine (Dell XPS 17) is available.

Any help appreciated.

nvidia-bug-report.log.gz (269.5 KB)

Yes, optimus is supported. prime-select nvidia- reboot - but I think Mint 20 ships with their own tools to manage GPU selection, but I don’t know them (just read the release notes).

One thing is, that I think your kernel is too old:

[ 1.289741] [drm] Your graphics device 9a60 is not properly supported by the driver in this
kernel version. To force driver probe anyway, use i915.force_probe=9a60
module parameter or CONFIG_DRM_I915_FORCE_PROBE=9a60 configuration option,
or (recommended) check for kernel updates.

May also apply to the audio problem.

[ 64.401880] snd_hda_intel 0000:00:1f.3: couldn’t bind with audio component
[ 64.409569] snd_hda_codec_hdmi hdaudioC0D2: No i915 binding for Intel HDMI/DP codec
[ 64.410858] hdaudio hdaudioC0D2: Unable to bind the codec

I’m quite sure Mint 20 comes with a newer kernel availabe…
Also there are BAR allocations errors in dmesg. Check for them after the kernel upgrade - I think the kernel parameter pci-realloc might or might not help with that, just try, it’s easy revertable and doesn’t hurt. Also make sure "Above 4G decoding is enabled in the Bios (might also be called something like “large BAR support”).

Works for me on both my PC and laptop.

Laptop: Dell XPS 17 (9700) with GTX 1650 Ti
PC: RTX 2070

OS: Fedora 34
Kernel: 5.14.5-300
DE: Gnome 40.4
Windowing System: both Wayland and Xorg
Nvidia Drivers (installed from RPM Fusion): 470.63.01-1

Thanks a lot!
In deed I did not realize Mint LTS was lagging that much by default (never had an issue until now) and I could have read dmesg better.
I upgraded to 5.11.0-34 and the card now seems to work :0)
Sound stays an issue, I will follow the leads you suggested.
Again thx.