No kernel shown in Nsight performance analysis

Hi,
I am new to CUDA and I just started to learn GPU profiling by Nsight. I have a NVIDIA GeForce RTX 3060. I installed CUDA toolkit v10.0(cuda_10.0.130_411.31_win10.exe), where the Nsight Visual Studio Edition is included. However, when I started profiling using matrixMul_vs2017 in the example code, I couldn’t find the kernel name in the report. Does anyone has encountered this problem before? I have tried uninstall/reinstall the driver, cuda toolkit, standalone Nsight system several times, but none of them worked.


CUDA 10.0 was released well before the RTX 3060, so this GPU is not support by the associated NsightVSE.

I’d recommended using CUDA 11.3 or downloading the the latest Nsight Tools.
Note that the profilers are no longer included in NsightVSE and are provided as standalone tools.
They do, however, integrate into Visual Studio.

This page provides information and links for each of the Nsight tools as well as how to integrate them into Visual Studio, if desired.