No Voltage on GPIO 10 (UART1_RX), Jetson Xavier AGX

Hello There,

should the RX Pin not at least show some voltage if measured to ground?

The GPIO 8 (UART1_TX) is on 3.3 V to ground. Thats what i would expect for RX as well. Is there a enable/disable setting on the board?


hello Benutzer493 ,

are you simply probe the pin voltage, or you’re having data transmit and evaluate the pin?

Hi JerryChang,

i want to make sure of the voltage before connecting it to other devices so i am just probing or measuring it.

Thanks for the response and Regards

The input pin should be high z status, not low or high.

Thanks for response Trumany,

Can you elaborate that a bit more?

I measured the same pins on my raspberry and it got 3.3 V on Rx and Tx to ground. I guess there is a difference between Raspberry and jetson regarding expansion header pinout.


There is a level shift to the pins on devkit. Is there any issue you met on UART1 port?

I will check it today! My guess is that, if i have no voltage on the pin, the pin is dead.

does anyone have a jetson xavier agx and could check the voltage of uart1_rx to ground on his product?

Here is my Update:

I connected the uart io of the raspy and jetson like:
tx raspy <-> rx jetson
rx raspy <-> tx jetson
gnd raspy <-> gnd jetson

my goal is to test the pins of the jetson. i know the raspy works fine.

jetson@jetson-desktop:~$ cat /dev/ttyS0
cat: /dev/ttyS0: Input/output error

is this what i should get if i make a simple cat on ttyS0?

thank you!

hello Benutzer493,

please try running the serial port utility, such as minicom or picocom to process the UART data.
in addition, it has been registered as ttyTHSx, whereas x are numbers for each node, you may looking kernel logs for $ dmesg | grep THS after kernel boot-up to check the UART mappings.
the default baud-rate setting is 115200/8n1, for example, you may enable a terminal and execute $ picocom -b 115200 /dev/ttyTHS3 to check the serial data.

That was it, thank you! It works!

so to wrap this up. The rx-pin has no voltage, but is still listening. i did

on jetson:
sudo minicom -b 115200 -D /dev/ttyTHS0 -o
on raspberry:
sudo minicom -b 115200 -D /dev/ttyS0 -o

and i could see response frome both sides. thx for the help

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.