No WIFI after kernel build


I recently built a new kernel and I lost WIFI, I checked and WIFI was being built as a module. I tried building it in (not as a module) and still no luck. Has anybody else had this problem? I figure there must be some config option I am missing.

Which L4T release is this?

head -n 1 /etc/nv_tegra_release

Assuming R24.2+ there is an initrd being used. Should something in WiFi need a file in the initrd must provide this (I don’t know if this is the case…once the system is booted initrd is not used anyway, but sometimes setup is required here).

As an item to check, does your new kernel use the same extlinux.conf configuration as the original kernel? Does this name the same initrd? Did you change CONFIG_LOCALVERSION (does “uname -r” change…what is the uname -r while the new kernel is booted)?

FYI, you can extract what is in an initrd to see what is there via:

mkdir /tmp/initrd
cd /tmp/initrd
gunzip < ~/Documents/embedded/L4T/R24.2.1/Linux_for_Tegra/rootfs/boot/initrd > initrd.cpio
sudo cpio -vid < initrd.cpio
# Browse around, especially "lib/firmware/"...if USB is involved this is required.
# Note that libraries used early on may show up here as well.
cd /tmp
# Get rid of the temp workspace:
sudo rm -Rf /tmp/initrd

You might also want to include the output of: