wlan0 issues on Jetson TX2

I recently received the Connect Tech Orbitty carrier board for the Nvidia Jetson TX2. I was previously using the TX2 module in the stock Nvidia development kit. After installing the TX2 into the Orbitty carrier, I reflashed it according to these instructions. After booting into the Ubuntu operating system and connecting a monitor, keyboard, and mouse to the Jetson TX2, I realized that I was unable to connect to a wifi network now. If I press the button in the top right corner of the Ubuntu desktop that would normally allow for Wifi connections, it just says “Ethernet Network disconnected)” with no option for wifi. JetPack was 3.3 and L4T 28.2.1.

I ran ifconfig and it only shows eth0, l4tbr0, lo, usb0, usb1. No wlan0.

rfkill list returns nothing

iwconfig

usb0     no wireless extensions
lo       no wireless extensions
dummy0   no wireless extensions
l4tbr0   no wireless extensions
usb1     no wireless extensions
tunl0    no wireless extensions
eth0     no wireless extensions

I am not sure what other commands to run to try and diagnose this. I have tried rebooting and reflashing via JetPack but it doesn’t fix the problem. Thank you for any ideas/assistance.

If wlan0 is gone, possible reason maybe the driver does not work.

It may come from

  1. firmware does not load or error
  2. kernel module does not load
  3. rfkill blocks wifi

For 1, please share full dmesg
For 2, please share “lsmod”
For 3, please share “sudo rfkill -list”

Thanks for your response. dmesg output is attached.

nvidia@tegra-ubuntu:~$ lsmod
Module                  Size  Used by
nvidia@tegra-ubuntu:~$

Nothing else.

nvidia@tegra-ubuntu:~$ sudo rfkill -list
Usage:	rfkill [options] command
Options:
	--version	show version (0.5-1ubuntu3 (Ubuntu))
Commands:
	help
	event
	list [IDENTIFIER]
	block IDENTIFIER
	unblock IDENTIFIER
where IDENTIFIER is the index no. of an rfkill switch or one of:
	<idx> all wifi wlan bluetooth uwb ultrawideband wimax wwan gps fm nfc

If you meant “sudo rfkill list” here it is:

nvidia@tegra-ubuntu:~$ sudo rfkill list
nvidia@tegra-ubuntu:~$

No output.

dmesg.txt (60.3 KB)

Sorry, it should be “sudo rfkill list all”.

But the answer here is obvious that you kernel module is totally empty. There is no driver there at all.
Did you install your board with fresh jetpack? or did you modify the kernel image?

Board was flashed with fresh jetpack. I only reflashed because I installed the module into the Orbitty carrier and I needed to reflash to get the USB ports to work. Since the wifi is on the module and not the carrier, I would have thought that it shouldn’t have been affected by the Orbitty update.

Is there a way for me to fix the kernel? Or install the driver etc?

Still not sure why lsmod has nothing. Under such case, even pcie should not work because pcie driver is also a kernel module.

Could you check if you have below path on tegra “/lib/modules/4.4.38-tegra”?
Also, could you share the result of “uname -a” ?

After installing Jetpack 3.3 was the directory copied to another location or system, such that to have a stock back up of L4T?

On some occurrences if Jetpack has been copied from the original install location you may encounter permission issues and conflicts with the root files of L4T. It is recommended to use a fresh installation of Jetpack when implementing the CTI Board Support Package.

Could you please run the following command to confirm the BSP release you are using on your system, our latest BSP is version V121. I have confirmed that the BSP does not effect the WiFi module with the Orbitty Carrier.

nvidia@tegra-ubuntu:~$ cat /etc/cti/CTI-L4T.version

The output will be the CTI BSP release.

It’s possible that PCIe isn’t working, I’m not using anything on the PCIe so I would have no idea if it wasn’t functioning. I don’t think the Orbitty has a PCIe port at all.

In the /lib/modules directory, I have two subdirectories: 4.4.38 and 4.4.38-tegra

uname -a returns:

Linux tegra-ubuntu 4.4.38-tegra #2 SMP PREEMPT Thu Mar 15 15:13:07 EDT 2018 aarch64 aarch64 aarch64 GNU/Linux

I didn’t have a stock backup of L4T, I just uploaded all of the software I had written to GitHub and then did a clean install of the CTI Orbitty BSP according to your guide. Unless that would result in a backup of the L4T, I don’t think I did a backup. I was intending to just reinstall the software from GitHub and make whatever modifications were necessary to work with the Orbitty (if any).

cat command:

nvidia@tegra-ubuntu:~$ cat /etc/cti/CTI-L4T.version
V112

Maybe I should try reflashing with V121?

It looks to be that you have installed our V112 release for L4T28.1.0, this release is not compatible with L4T28.2.1 that is included with Jetpack 3.3.

Please use the following link to download our V121 release, you may apply this BSP to the same Linux_for_tegra directory that V112 is installed as it will replace the older release when the installation is executed.

L4T28.2.1 Jetson TX2, V121
http://www.connecttech.com/ftp/Drivers/CTI-L4T-V121.tgz

Auto load could only find the modules which match your result of “uname -a”. That is, if your “uname -a” is “4.4.38-tegra”, you have to check if bcmdhd (wifi driver) is under /lib/modules/4.4.38-tegra.

If there is no such driver, auto load would not work and lsmod would show nothing as current case.
I mentioned tegra pcie driver because it is the same case here.

Sorry, it’s been a while but I reflashed the board with V121 and it didn’t work the first time. However, after a second reflash, the wifi seems to be back and working. Not entirely sure what the issue was, but I’m just going to hope it doesn’t come up again.