Custom TX2 image has no WiFi


We have a custom carrier for our TX2 NX, and for the last months we’ve been making some changes to the kernel and dts, mostly adding drivers for new peripherals and device tree adaptations. We usually have a main .img file we use to flash any jetson, so it’s ready to go.

Recently, newly flashed TX2 started to have no WiFi, and honestly we have no ideia why. We are assuming it’s something on our part, obviously, but we don’t have any idea where to start looking. All the changes to the kernel are in version control and we can be sure that there’s nothing that would mess with wifi.
So I’m really looking for ‘debugging’ tips as in, where should I start looking, potential things that come to mind, anything that could help us find out what the problem is.

I’ll attach this images to show what I mean when i say we don’t have WiFi:

And nmcli d w has no output, is completely empty.

We are testing on a carrier module, we’ve used multiple WiFi modules, multiple antennas, and multiple jetsons. We are sure it’s not a hardware problem because we have one jetson that is able to get WiFi (that wasn’t flashed recently ). We’ve tried cloning that into a new image and flashing it another jetson and they don’t have WiFi still.

Any tips on what it would be and/or where should we start looking?


What interface does this wifi use? PCIe?

Yes, PCIe.

Does “lspci” show this card?

With the only TX2 NX we have with working WiFi, it shows:

00:01:0 PCI bridge: NVIDIA Corporation Device 10e5 (rev a1)
01:00:0 Network controller: Intel Corporation Wireless 8265 / 8275 (rev 78)

With any other jetson (and I mean any jetson we flash with our current setup), the output of lspci is completely empty.

Sorry, what is the exact platform that has issue here?

If by platform you mean the carrier for the TX2 NX, this issue is happening the on both our custom carrier and the
nvidia carrier.

You can assume i’m doing all tests on the default carrier.

I think I didn’t make it clear.

My question should be

  1. What is the exact card in use here? Is “Intel Corporation Wireless 8265” the card you are talking about?

  2. If so, what was not working? What did you change and the card would be gone?

  3. I have no idea about what does that mean it cannot work on custom board and nv carrier but not default carrier. What is default carrier ? Why default carrier is not same as nv carrier?


1- We are using this Intel - 8265.NGWMG.DTX1
2- What is not working is, we are not able to connect to WiFi at all, as shown in the image in the first post. Now with the lspci command outputting empty, we know the module is not being seen.
The main point here is. we have one TX2 that has a working WiFi, and the more recent ones don’t. So it’s a software problem for sure.
As for what we did we change to trigger this? I’m really not sure. I’ve looked at the changes we made to the kernel source and nothing obvious indicates to me that I’ve done something that could change this.
3- I’m sorry I was being confusing. What I mean is, we have two boards where we test. Our custom board, and the development kit carrier. I was saying that the problem persists on both boards, so you can assume I’m testing everything on the development kit.

Thank you for your answer.


Still not sure if I understand correctly…

Is your “TX2” equal to “TX2-NX” or you are really talking about TX2 but not TX2-NX?

Sorry again! TX2 NX! not TX2. I will be more clear in the future, but I do mean TX2 NX.

Ok, so you are talking about you receive some new TX2-NX “modules”, you plug them to your NV devkit and flash with jetpack and it cannot detect intel 8265 wifi card in lspci?

We have a custom tx2 nx image ready to flash any new module that comes in, plus a modified kernel. (Since we do also use a custom carrier board).

The thing is, the recent modules that came in, when flashed, they don’t detect the wifi card. And i’m not sure what triggered this, since it used to work just fine.

Now, I’m assuming it’s something we did wrong, but something I can’t trace back to what exacly.
We have our changes kernel in source control, and I can’t spot anything obvious that could affect it.

Does that make sense?


Honestly, I only care about what is the status on devkit at this moment. Could you tell me if these new modules could see this wifi card on devkit or not?

No, they cannot see the wifi card on the devkit.

Could you check if those modules are affected by this PCN? I don’t see any other new TX2-NX module PCN here.

Yes, they all are. All part numbers are in this format 900-13636-****-***

I’m not sure if it was clear but we have a TX2 NX that we flashed quite a while ago, that is able to detect the module and can connect to wifi (and falls under that PCN).

Now we cloned an image from that TX2 NX with working wifi, and cloned it into the new modules, and we can’t detect the wifi card on those.

let me try to reproduce this issue first. Thanks.


Hopefully this helps. Sorry for not being full dmesg logs but, because i don’t have wifi, it’s harder for me to pull them all.

Will also attach my main dtb, in case its helps aswell.
tegra186-p3636-0001-p3509-0000-a01.dts (239.8 KB)

Hi. It is solved.

It was my mistake.

A couple of weeks ago, we we’re trying to setup the SSD, without any success due to board design issues, and forgot about it. But i left some code I was using to test it in the device tree, on the pci-controler. After reverting for what it was, it was solved.

Thank you for your help and patience.
There’s not really a solution answer I’d say so you can close this topic.