tx2 no desktop, no network, no wifi, help!

No desktop appears when I boot up, only the command line!

When I login, system hint:This system has been minimized by removing packages and content that are not required on a system that users do not log into.

I can’t flash a new OS, what should I do? I want to restore the desktop




Is your monitor purely HDMI without any adapters? Is there anything unusual about the monitor? In most cases where the system otherwise boots normally (and the console message you saw indicates normal boot) this becomes a question of video configuration. By far the most common problem is losing the automatic configuration data via adapters from monitors which do not have HDMI.

Note: I am assuming the monitor never worked and that this is what you see after a flash. Correct me if the unit was working before this with that monitor.

My display is no problem. Originally there is a desktop. After installing a remote desktop software, the system automatically restarts, and then the desktop is not displayed.

My display is no problem. Originally there is a desktop. After installing a remote desktop software, the system automatically restarts, and then the desktop is not displayed.

I have insufficient knowledge to debug what goes wrong with remote desktop software. However, if you have text console, or ssh, or serial console, then you can post logs and this should be useful in knowing what is going wrong. Quite possibly the original desktop software was replaced or configured incorrectly, and logs may help.

Among all of the methods of access, the serial console will be preferred since this can show even boot stages prior to Linux starting. This software has no requirements for video or networking. See:
http://www.jetsonhacks.com/2017/03/24/serial-console-nvidia-jetson-tx2/

If you can get a boot log (serial consoles can log), this would be preferred. If not, then after boot the “dmesg” output would be nearly as useful.

Additionally, run the command “ls -ltr /var/log/X*.log”. The last file listed will be the most recently updated log for the desktop graphics (probably “Xorg.0.log”, but since things didn’t work, this may not be the case). You can rename this with a “.txt” extension, and attach to the forums (if you hover your mouse over the quote icon in the upper right of one of your existing posts, then other icons will show up…the paper clip icon is for file attach).

You might also want to mention which L4T release you have (run “head -n 1 /etc/nv_tegra_release”), and which remote desktop software you installed.

I have uploaded four pictures. That is the content of “Xorg.0.log”
When I run “head -n 1 /etc/nv_tegra_release”, shown as:"# R32 (release), REVISION: 1.0, GCID:14531094, BOARD: t186ref, EABI:aarch64, DATE:Wed Mar 13 07:41:08 UTC 2019"
I installed a remote software named SunClient, I download from https://sunlogin.oray.com/personal/

It is difficult to search within the photos. If you use a serial console to cat the log file, then it will log in the serial console on the host. If this is not possible, then look for any modes where you see something like either of these:

Mode "1680x1050_60" is valid.
...
Mode "640x400_85" is invalid.

The goal is to find out if valid modes are present, and if the selected mode is from that list.

I have no knowledge of that particular remote desktop software, so I don’t know if it can work or not. Keep in mind that we do not know if that software is intended to replace existing software, or if it is intended to run on top of existing software. If anything is replaced, then it is possible that the NVIDIA GPU software was replaced. One test you should run and look to see if anything is not “ok” is this:

sha1sum -c /etc/nv_tegra_release

I reinstalled the system and it worked.thank you for your help!

Same situation here. Is there any cure but installing the whole system again?

It is probably better to start a new topic since there are many reasons why the GUI may not start (or appear to not start) even though the system is otherwise running normally. That said, the most common problem is using a monitor without true HDMI (e.g., a VGA-to-HDMI adapter breaks things). Next to this, you would want the flash to have been performed with a monitor/keyboard attached during the flash as this could change the installation.