Jetson TX2 cannot start - fix and avoid

I power on my Jetson TX2, it displays the boot screen but then it does not display properly the desktop unity. It does not display the menu items/icons, it just flicker some files I have saved on Desktop and that´s all… After I pressed the restart button it doesn’t display anything anymore. Please check the videos and picture below.

I am not even able to open with Ctrl + Alt + F1

Last time I worked on the TX2, everything seemed to work properly.

  1. Is there a way to fix this without flashing?
  2. If we flash it, is there a proper way to easily restore all the packages and data? Some sort of container, bash script etc.
  3. Is there a way to avoid such complete failures, considering we are building a dependable autonomous vehicle?

CTRL-ALT-F2 would be a pure text console. Is this available?

Typically GUI autoconfig can fail without the Jetson otherwise failing, e.g., lack of video would not typically stop serial console or ssh access. Losing video is not a reliable indicator of the system failing.

Can you access via ssh? Do you have a serial console (the best method of seeing what is going on)? If interested in serial console (every developer should have this available if serious) see:
http://www.jetsonhacks.com/2017/03/24/serial-console-nvidia-jetson-tx2/

Knowing what access you have is important to figuring out what you can do for debugging.

HDMI is hot plug, so if it fails, then you might try unplugging it and re-plugging it after boot, or else just leaving it disconnected during boot and seeing if plugging it in after boot causes it to work. This assumes it is a true HDMI monitor and not VGA (if any component of the path is VGA it cannot self-configure…you’d have to be lucky with default modes). Some (most?) adapters for DVI (not all), and HDMI-to-DisplayPort are ok to use. There is no such thing as a 15-pin D-Sub VGA connector capable of self configuration.

Clone details can change depending on release, but which version is this Jetson running? For clone information, see:
https://devtalk.nvidia.com/default/topic/1000105/jetson-tx2/tx2-cloning/

FYI, clone produces a “sparse” (pseudo compressed) image (file name ending “.img”) and a raw (uncompressed) complete image of the file system (file name from clone software uses “.img.raw” suffix). I typically throw out the sparse image, and then keep only the raw image. The raw image works just as well for flash (but takes longer), and can be loopback mounted on the host PC for seeing what is there in addition to being able to flash the image directly back on to the Jetson (it’s a great backup tool).

Thanks for a prompt and detailed reply.

We tried CTRL-ALT-F2, but my colleagues opened a parallel thread for the results:

https://devtalk.nvidia.com/default/topic/1038630/flashing-fails-jetson-screen-flickers/#5277073

Apparently they couldn’t even flash it. Any advice?

(Also, we can close one of the threads if it is according to the forum rules)

I added a question in the other thread.