Cannot get Display to work

Hello,

So I have had my Jetson tx2 for almost months and it has been working great. Until today when I accidentally caused a little spark when connecting my onboard battery and since then have not been able to get my usual displays which I have been using for three months to work.

I re-flashed my Jetson with jetpack 3.3 and the screen did not boot up except for the nvidia logo and a little bit of the bootup script. I was able to ssh into system which suggests that the OS is functional. The screen comes up once in a while where the image is blurry and shaky for like half a second. Not sure what is wrong.

I was in the final stages of my project. Any fix to this will be greatly appreciated.
edid.txt (783 Bytes)
Dmesg.txt (63.4 KB)
tegradc.txt (1.51 KB)
tegra_release.txt (2.81 KB)
Xorg.0.log.txt (12.3 KB)
tegradc.0.txt (237 Bytes)

Which release are you using (see “head -n 1 /etc/nv_tegra_release”)? Do all files show as “ok” from:

sha1sum -c /etc/nv_tegra_release

If you hover your mouse over the quote icon of an existing post you will see other icons show up. One is a paper clip icon for attaching files. If you can save your “/var/log/Xorg.0.log” (and if present, then additionally include “/var/log/Xorg.1.log”) with a “.txt” file name extension. With the “.txt” file name extension you can then attach them to your post. You might also post the full output of “dmesg” (you could log it via either serial console or via “dmesg | tee log_dmesg.txt”).

Here are all the files. I added a couple of extra outputs from (https://elinux.org/Jetson_TX2/r28_Display_debug). I have attached them to the original post.

EDID checksum is valid. Some of the display’s modes seem fairly standard, so the monitor should work if the clocks are not out of range.

I see this which suggests it should be working in 1920x1080 mode:

[   722.416] (II) NVIDIA(0): Setting mode "HDMI-0: nvidia-auto-select @1920x1080 +0+0 {ViewPortIn=1920x1080, ViewPortOut=1920x1080+0+0}"
[   725.828] (II) NVIDIA(0): Setting mode "HDMI-0: nvidia-auto-select @1920x1080 +0+0 {ViewPortIn=1920x1080, ViewPortOut=1920x1080+0+0}"
[   725.876] (EE) NVIDIA(0): Failed to set the display configuration.
[   726.078] (--) NVIDIA(GPU-0): Sceptre E24 (DFP-0): connected
[   726.078] (--) NVIDIA(GPU-0): Sceptre E24 (DFP-0): External TMDS
[   726.089] (II) NVIDIA(0): Setting mode "HDMI-0: nvidia-auto-select @1920x1080 +0+0 {ViewPortIn=1920x1080, ViewPortOut=1920x1080+0+0}"
[   727.225] (II) NVIDIA(0): Setting mode "HDMI-0: nvidia-auto-select @1920x1080 +0+0 {ViewPortIn=1920x1080, ViewPortOut=1920x1080+0+0}"

All NVIDIA-specific files look to be valid checksum.

From what I can see it looks like the monitor should be working. HDMI is hot-plug, so if you unplug and replug the monitor while running, does it start working? Or if you keep the monitor unplugged during boot, but plug it in after boot, does this change anything?

Hi,

That is what I got when I went through the logs as well with no big red flags.

I tried the hot-plug method and waiting till complete boot to plug into no avail. The most I get when the monitor is plugged in while booting up is the Nvidia logo and the boot-up scroll then it goes blank.

I am afraid it may be a fundamental issue with the hardware.

So I tried flashing Jetpack 4.2 and this screen popped up for initial information. However, it blanked out just before the desktop was forming.

Here is figure.

I am assuming the TX2 was operating with that monitor in the past, and that it wasn’t just some miracle luck that allowed it to work…the assumption is this monitor could and should work with the TX2. Every indication in logs says this is the case.

I’ve seen video card failure before where the background starts losing content in that manner. I do believe this is hardware failure. If you can still RMA I would advise doing so. Otherwise the unit can probably still be used in text/console mode. It is possible that CUDA could still be used with a virtual desktop server (an X server might be made to work with a real monitor, or it might be designed to work with a virtual/fake monitor…in the latter case some of the GPU hardware which is possibly bad could be ignored…you’d have to test to find out).

If you can RMA you will see some RMA information near the top of this:
https://devtalk.nvidia.com/default/topic/793798/embedded-systems/some-jetson-web-links/

Hi,

You are correct I have been using the same monitor for the past 2 months.

I think I am still in the window for RMA. We have only had the board for three months. I will look into it. Thanks a lot for the link.