not mach-o or bitcode

Hello to everybody. I am new to CUDA and I wanted to check out if can run some simple example

I run OS X 10.6.4 on MBP with the 320M
I installed

And I tried to make the examples on
/Developer/GPU Computing/C

First I got errors like
ld: in …/…/lib/libcutil_i386.a, archive has no table of contents
I fixed this with ranlib on the .a files.

Now I am stuck with
ld: in …/…/lib/libcutil_i386.a(889352), archive member ‘889352’ with length 0 is not mach-o or bitcode
And I do not have any idea how to fix it. Google seems empty as well.
Do you have anything to suggest?
Thanks a lot

Did you set up environment variables as described on page 10 of the Getting Started… guide? (This guide is available at…rtedMacOS.pdf.) I’m copying the relevant lines here:

[indent]Define the environment variables.

● The PATH variable needs to include /usr/local/cuda/bin.

● DYLD_LIBRARY_PATH needs to contain /usr/local/cuda/lib.

The typical way to place these values in your environment is with the following commands:

export PATH=/usr/local/cuda/bin:$PATH

export DYLD_LIBRARY_PATH=/usr/local/cuda/lib:$DYLD_LIBRARY_PATH[/indent]

Hello, thanks a lot for the message.

Yes I have these folder in my path and in my dynamic libs path

~>echo $PATH


[Sat Jul 24 00:18] roberto@robertos-MacBook-Pro.local:/~



Honestly I am rather disappointed that the examples are not compiling … I think I did everything according to the instructions. Maybe I missed some step in my installation, can someone point some installation guide more detailed than that PDF? I was following exactly that document :(



It seems as though your library utilities are not behaving the way NVCC expects. Are you using the standard gcc toolchain that comes with Snow Leopard? Or have you installed a variant?