Notebook: 1060 + Intel: No external Monitors with "select-prime intel", Driver 381.

Hello all,

I am here with a new Notebook (XMG P507) with Kaby-Lake CPU and a Nvidia 1060 graphics card.
Using various Ubuntu systems (16.06/17.04) and installing the nvidia-381 driver leads to the following problem:

Selecting “nvidia” in the PRIME profile leads to a perfectly working system :)

Selecting “intel” in the PRIME profile makes it impossible to use external monitors, the output of “xrandr -q” is just

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
1920x1080 60.02*+ 59.93 47.99
1680x1050 59.95 59.88
1600x1024 60.17
1400x1050 59.98
[ … ]
512x384 60.00
400x300 60.32 56.34
320x240 60.05

In the nvidia profile, there are 4 additional DP ports and a HDMI port listed. Seems like the outputs are wired to the Nvidia card. On my previous system (Nvidia 750M GT) all ports were visible in both modes.
With Windows, there is also no problem with using external monitors via Intel card.

so my Question is:
Is there any possibility to connect external monitors in the intel profile? Will it be worth waiting for a new driver release?

Best wishes,
Patrick

Simple answer: no.
Your external connectors are connected to the nvidia gpu only. When in intel mode, the nvidia gpu is offline, so no output to external displays, not driver related.

Thanks for the answer, but are you sure?
I just checked the situation in Windows 10, there is no Nvidia GPU activity when I connect a monitor via DP and it works perfectly.

Problem is, in Linux and Nvidia mode the fans of the GPU are turning constantly and I haven’t found a way to lower the fan speed. Since I don’t do any heavy-GPU stuff on Linux, it is a little annoying.

Pretty much sure. If the external output is connected to the dGPU, how would it be possible to display something without using the dGPU? Some post from Dave Airlie, hes hould know better than me:
https://lists.freedesktop.org/archives/xorg-devel/2016-June/050148.html

About the fans constantly spinning: did you check with nvidia-settings a) gpu temperature (Thermal Settings) and b) running in Adaptive Mode and throttling down (PowerMizer)? Do the fans also spin if running on Battery?
Edit: just looked up your hardware and it seems that Schenker, or better said Clevo, implemented their own cooling system running special software under Windows. Maybe look up lm-sensors, pwmconfig, fancontrol for a linux equivalent.

Hi,

a) gpu temperature (Thermal Settings)

Yes, but I cannot adjust anything. Setting “cool-bits” in xorg.conf had no effect. If temp reaches 50°C fans go up. (then sometimes quiet for a minute, 90% of time fans are on)

b) running in Adaptive Mode and throttling down (PowerMizer)?

Already tried. I cannot change anything either.

Do the fans also spin if running on Battery?

Yep :(

Seems the gpu fan control is hardcoded in bios, only cpu fan is user controllable. Many people are complaining about it also running Windows. Have you tried updating your bios?
Other than that you could force the gpu to lowest state by adding to the device section in xorg.conf

Option  "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerLevel=0x3; PowerMizerDefault=0x3; PowerMizerDefaultAC=0x3"

as noted here:
http://guilleml.wordpress.com/2011/04/27/nvidia-powermizer-on-linux/
and hope this will keep the gpu temp below the threshold of 50°C. Though running on battery should already do this.
Edit: won’t work, I think when an external display is connected, the nvidia gpu will always throttle up.

Thank you!
I will look into it tomorrow an give a report :)

Hi!

It looks like setting

Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerLevel=0x3; PowerMizerDefault=0x3; PowerMizerDefaultAC=0x3"

leads to the desired effect!
“NVIDIA X Server Settings” displays the performance level constant at 0 and the temp is around 45°C. Fans are spinning, but almost silent!

Thanks!

Now I can work with my setup. Only switching between “intel” and “nvidia” to go mobile is annoying. Maybe there is a solution to connect monitors via DP or HDMI in intel mode, just like it is possible in Windows 10.

Did you check if a newer bios version exists? Still, you should complain to Schenker. They know about the misbehaving gpu cooling and asked Clevo to change it without much luck. Yet some more pressure could help.
The only possibility to use the external outputs and intel for rendering would be reverse PRIME which only works with the nouveau driver.