Nothing displayed when booting Xavier, but can SSH


After having flashed the Xavier without any problem, we have now an issue when trying to boot it. When powering it on, the nvidia logo is displayed on the screen, and then nothing. The screen will eventually enter low power mode. However, the Xavier is running, we can even SSH into it.

Do you know how to get the screen back?
Thank you in advance.

It sounds like video auto configuration is failed. Is the video purely HDMI, or is there any adapter? Is there anything unusual about the monitor?

What do you get from:

sudo -s
cat `find /sys -name edid`

Thank you for your answer.
The initial setup was indeed using an adapter, from HDMI to DVI. Using an other screen with HDMI-HDMI cable was working.

The output of your commands is:

 00 ff ff ff ff ff ff 00 4c 2d 66 01 37 31 4a 4d
 15 0f 01 03 80 22 1b 78 2a aa a5 a6 54 54 99 26
 14 50 54 bf ef 80 81 80 71 4f 01 01 01 01 01 01
 01 01 01 01 01 01 30 2a 00 98 51 00 2a 40 30 70
 13 00 52 0e 11 00 00 1e 00 00 00 fd 00 38 4b 1e
 51 0e 00 0a 20 20 20 20 20 20 00 00 00 fc 00 53
 79 6e 63 4d 61 73 74 65 72 0a 20 20 00 00 00 ff
 00 48 53 43 59 35 32 32 30 33 34 0a 20 20 00 dc

it seems that some adapters may have issues while being used with some certain monitors.
In my case hdmi-> vga worked somehow, as far as I remember. Though I switched to use of usb-C monitors after.

That looks like there are multiple monitors. Is this EDID output from only one monitor?

VGA won’t work except by luck…if a default mode works with the monitor, then it works, but can never be relied on.

DVI mostly has EDID, though some of the adapters don’t cover digital and lack EDID pass-through. I’ll say that “most” of these work, but not all.

Pure HDMI should always work, but you can get lower quality cables or too many adapters and loss such that it still doesn’t work.

The EDID which does appear shows a fairly standard older style 4:3 aspect monitor. Although it doesn’t support something common to modern monitors, such as 1920x1080, it does support a lot of 4:3 modes and should probably have something valid showing up.

I am curious…since two failed EDIDs are listed, plus one working, how many log files do you see from:

ls -l /var/log/Xorg.* | grep -v old

I included the “-l” option to see dates…I’ve experimented in the past and have several old log files, and I’m only interested in recent log files.

FYI, if you hover your mouse over the quote icon in the upper right corner of one of your existing posts, then other icons will show up. The paper clip icon is for attaching files. You might consider attaching the log file for any recent Xorg log (you’ll likely need to rename them with a “.txt” file name suffix).