NPP how to compile the NPP sample code in linux

Hi all,

I downloaded the NPP library for linux, but “make” gives errors for the sample files given.
I am using CUDA2.0. Is NPP compatible with this version of CUDA?

Thanks !

NPP is based on the CUDA Runtime API Version 2.3. Developing software with NPP,
requires a CUDA 2.3 compatible driver, and the CUDA 2.3 toolkit.

Hi Frank,

Thanks a lot… I updated to CUDA 2.3, but make still gives errors. Any pointers to understand the problem will be helpful!


Hi Subarna,

what version and type of Linux are you using? Is it one of our officially supported types?

I use Yellow Dog Enterprise Linux 6.2 for CUDA ( which already integrated CUDA SDK 3.0 and CUDA Toolkit 3.0. However, I could not do “make” as Subarna did.

The Yellow Dog Enterprise Linux 6.2 for CUDA (YDEL_C) is based on CentOS. I think YDEL_C developers removed some libraries from the original distro.

This is the error occured:


I have one doubt regarding using NPP with CUDA.

Do i require a GPU to run the NPP functions , or can i run it in emulation mode.

Currently i’am not having a GPU. i have included all the necessary NPP library and header files to my project. But when i run the program, i get some link errors.

Is this the problem because i dont have a GPU installed in my PC

Thanks Sarath

The errors (sreenshot in your post) indicate that the CUDA runtime header files are not found. I believe the make files do rely on CUDA_INC_PATH, etc. to be properly set in your environment. You might want to check if those are exported and valid.

Since CUDA 3.1 release emulation mode is not supported any more. So if you want to continue NPP development you’ll need a GPU. Proper linking of an NPP (and generally CUDA) application is not dependent on having a GPU in the system. You couldn’t successfully run what you comipled though.