Nsight 3.2 crash when using cuda debugging

When using ‘CUDA Debugging’ with Nsight sample (matrixMul) will led to a crash.
Does anyone have same problem like this?

CrashLog
Problem signature:
Problem Event Name: APPCRASH
Application Name: matrixMul.exe
Application Version: 0.0.0.0
Application Timestamp: 52673127
Fault Module Name: nvcuda.dll
Fault Module Version: 8.17.13.2723
Fault Module Timestamp: 52314ff8
Exception Code: c0000005
Exception Offset: 000000000004844e
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 1028
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

SelfTest: (already added or set)

  1. Project Properties - Generate Debug Information(-G)
  2. Nsight Monitor - WDDM TDR Set to false
  3. Add BreakPoints inside kernel function
  4. Running without ‘CUDA Debugging’ works fine
  5. Other Example have same problem

SystemInfo

  1. Display Info: Geforce GTX 660 Ti / Driver: 327.23
  2. CUDA toolkit: 5.5
  3. Nsight 3.2.0.13289
  4. IDE: visual studio 2010 4.0.30319

Contains of Console Window:
[Matrix Multiply Using CUDA] - Starting…
GPU Device 0: “GeForce GTX 660 Ti” with compute capability 3.0

MatrixA(320,320), MatrixB(640,320)
Computing result using CUDA Kernel…

Hi,

That is not good. We have not seen this. A couple of questions:
Does it happen with more than just that one sample?

Which OS and bitness?

Do you have more than just the GTX 660 Ti in the system for GPU?

Did you happen to keep the dump file, and if so, could you attach?

Thanks

-> I tried CUDA example (matrixMul and vecAdd), but all result failed.

-> Windows 7 x64 SP 1

-> No, there is just one display card on my PC.

-> I’m not sure what you want, could you explain more about the “dump file”?

-> Thanks for your reply : )

Hi flysnow,

I assume that the application runs fine outside of Nsight debug? Could you try reinstalling your graphics drivers with the “Perform clean install” option checked?

-Jeff

Hi Jeff, thanks for your response

-> Yes, and I said that in Self Test - 4. Running without ‘CUDA Debugging’ works fine :)

-> I tried “clean install” of driver 327.23, but unfortunately it doesn’t work

Hi flysnow,

Who is the manufacturer of your card, and what is the full name name of the card?

Thanks,

-Jeff

Hi Jeff

I tried two display card GTX 660 Ti
one comes from LeadTek (http://www.leadtek.com/eng/product/1/646/intro.aspx)
the other comes from EVGA (http://www.evga.com/products/pdf/02G-P4-3660.pdf)
but still crash when using CUDA Debugging

b.t.w.
I want to send you something in another article by gmail, but the mail was reject by the server,
so how do I send things to you?