Nsight Graphics Debugging throws error and the application crashes

Hello everyone,
when I run the Graphics Debugger (Build Number: in VS2010 I get this (strange) error:

Couldn’t locate procedure “DXGIGetDebugInterface” in “dxgidebug.dll”

I can “bypass” this by clicking the OK button on that error but my application (what I develop on VS) hangs up saying “blabla.exe doesn’t work anymore” after that.

I also tried reinstalling everything (directx sdk, Nsight and VS) but without success.

Trying the new 3.0 RC produces the same error.

Looking up this kind of problem on google or in this forum didn’t give me a single hit, not even one error talk is close to what I get.

Please tell me if you need more informations to investigate the problem.


Would you mind installing the Redist that ships with the DirectX SDK, and try again? Which version and bitness of Windows is this? Also, which GPU are you using?

Thanks for the respond.

Installing Redist didn’t help. I got Windows7 64 bit and a GTX 480.

Which DirectX SDK release are you linking against?

Microsoft DirectX SDK (June 2010)

Is dxgidebug.dll located in your path? Some users on the internet are noting that the file is permanently deleted when certain versions of the DX SDK are uninstalled.

dxgidebug.dll is located in the appropriated windows folders, I also tried copying it to my project folders. The dll is actually found but I get an error that the procedure DXGIGetDebugInterface could not be located.

I found a post where someone fixed the problem (BF3 threw this error) by renaming the dxgi.dll to dxgidebug.dll (a bit weird to fix it this way, but however I tried it), however I still get the error.

That’s really odd. Would you mind trying to debug a DirectX SDK sample application and see if the error occurs there as well?

Thats interesting, debugging the CascadedShadowMaps11 sample (for example) doesn’t produce the error. It seems it has something to do with my project settings, but I have no clue what it could be.

I would take a look at the Linker settings for your project. Some possible reasons could include linking incorrect DirectX libs or using mismatched run-time library settings.