Nsight Systems:Failed to launch daemon

Recently I used nsight sysytems to monitor the parameter status of the host’s GPU while it was running, but after starting nsight systems I could not connect to the host, and the following error occurred:


My nsight systems failed to launch daemon,but cuda programs can run normally. I have changed multiple versions of nsight systems and they all have the same problem, please tell me how to solve it, thank you!
My nsight systems version is 2020.3.1, CUDA version is 11.1.0, driver version is 512.78, and operating system is windows11.

To be clear, you are running a Windows x86 system and attempting to analyze that same system (analyze localhost)?

I know you say you have tried multiple versions of Nsys, so I apologize, but the version you are listing there for Nsys is 3 years out of date. So, yeah, the first thing I am going to recommend is that you go to developer.nvidia.com/nsight-systems and download 2023.4.

Also, please look at your running processes and make sure that there aren’t zombie Nsys processes on the system.

Thank you for your reply.

I am running a Windows x86 system and trying to analyze the same system (analyze the local host), the system version is Windows11.

The Nsight Systems version of 2020.3.1 I listed is the version that came with CUDA11.1.0. The multiple versions I tried included the latest April 2023 version, but had the same issues when using it.

The zombie Nsys process should not exist, because I used Nsight Systems to analyze it immediately after restarting the computer, but it still reported an error.

By the way, my GPU version is the NVIDIA Geforce RTX3060 Laptop. I don’t know if the graphics card is not applicable, because I have no problems using this version of Nsight Systems on the GTX 10050TI and RTX3090.

@dofek can you please take a look at this?

Hi liuwei_hfut,

Please install the latest Nsight Systems release from https://developer.nvidia.com/nsight-systems/get-started#latest-version (currently this is release 2023.4.1). Can you collect a log and share it with us to help us debug this issue?

  1. Close nsys-ui and nsys.
  2. In the Nsight Systems host-windows-x64 directory, there is a file named nvlog.config.template. Rename this file nvlog.config
  3. Re-run nsys-ui and try to start the trace session.
  4. Afterwards, there should be a file named nsys-ui.log in your host-windows-x64 directory. Please share that file (nsys-ui.log) with me.
  5. Delete the nvlog.config file from the host-windows-x64 directory.

nsys-ui.log (14.9 KB)
I followed the process you described and the resulting nsys-ui.log is shown above. The problem with Nsight Systems is the same as usual. Please analyze it. Thank you.

Hello! Can you find out what causes this?@dofek