NTP time stamp is always 0

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU)
• DeepStream Version
• JetPack Version (valid for Jetson only)
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

Jetson Orin AGX 64 GB
Deepstream 6.4
Jetpack 6.0 DP

I am trying to follow this NTP Timestamp in DeepStream — DeepStream documentation 6.4 documentation to inject the camera timestamp into the frames - which hopefully would be one way to synchronize inference events and RTSP streams.
I am running a pipeline using the python bindings.

So I am setting “attach-sys-ts” to False for my streammux element and for each subsequent source bin I am adding, I set:

source_bin = create_source_bin(i, uri_name)

I made sure that I do get rtcp sender reports from the camera.

sudo tshark -i eth0 -f "src host" -Y "rtcp"
Running as user "root" and group "root". This could be dangerous.
Capturing on 'eth0'
 ** (tshark:761399) 12:43:18.480965 [Main MESSAGE] -- Capture started.
 ** (tshark:761399) 12:43:18.481131 [Main MESSAGE] -- File: "/tmp/wireshark_eth0FL3TN2.pcapng"
  650 2.432151296 →  RTCP 90 Sender Report   Source description   
 2009 7.441518098 →  RTCP 90 Sender Report   Source description   
 3418 12.421586267 →  RTCP 90 Sender Report   Source description   
^C 4781 17.431802330 →  RTCP 90 Sender Report   Source description   
4 packets captured

Yet, frame_meta.ntp_timestamp is always 0.

I think this topic has been touched a number of times, but the solutions seem either unclear or not exactly applying to my situation.

Have you tried the sample deepstream_python_apps/apps/deepstream-rtsp-in-rtsp-out at master · NVIDIA-AI-IOT/deepstream_python_apps (github.com)?

You should set pyds.configure_source_for_ntp_sync

Check this code

yes - that actually helped!
Looks like I was calling pyds.configure_source_for_ntp_sync(hash(source_bin)) in the wrong place.
Good to know it actually has to be called in the decodebin_child_added function.