Numba package (in python) on Jetson

Has anyone succeeded in install numba in python 3.5 on Jetson TX1? I tried to build numba from source.

Hi,

We don’t have the experience on numba for Jetson.

From this document, they don’t officially support ARM platform yet.
http://numba.pydata.org/numba-doc/0.35.0/user/installing.html#compatibility

<b>1.2.1. Compatibility</b>

Numba is compatible with Python 2.7 and 3.4 or later, and Numpy versions 1.7 to 1.13.

Our supported platforms are:

    Linux x86 (32-bit and 64-bit)
    Windows 7 and later (32-bit and 64-bit)
    OS X 10.9 and later (64-bit)
    NVIDIA GPUs of compute capability 2.0 and later
    AMD APUs supported by the HSA 1.0 final runtime (Kaveri, Carrizo)

Maybe you can check with the developer if they are going to support ARM platform in the future.
https://github.com/numba/numba/issues

Thanks and sorry for the inconvenience.

At this time you can install numba on a TX2 but version 6 of libllvm from the Ubuntu apt repository has a bug that prevents it from running. The llvmlite GitHub site has the patch required to build a working version of libllvm. If the llvmlite team would publish a binary wheel for arm64 then we’d be in business (They have published such wheels for other platforms).

It is apparently supported now: https://numba.pydata.org/numba-doc/dev/release-notes.html#version-0-40-0
PR #3128: Fix recipe/build for jetson tx2/ARM

I got numba installed by installing the needed LLVM 7 (onto an SD card). Similar issue mentioned here which led me on this information chase: https://github.com/numba/llvmlite/issues/360#issuecomment-416171994

Install LLVM version needed (see note below about installing on SD card, which may also apply to hard drives) https://gist.github.com/jed-frey/ba40ff83523296bc8355f05befb28da9 (I had to alter the instructions here slightly to get it to work, like not using some of the cmake flags)
SD install with symbolic links: SD card needs to be formatted as EXT4 (reference: https://www.raspberrypi.org/forums/viewtopic.php?t=59538)

I believe it works after that!

Thank you all.
I managed to build LLVM-7.0.1 on jetson and numba is working on it.

Hi ben.p

How to install numba on your jetson?
Can you share it to me?

Thanks

Hi yohan, I put a tutorial here https://github.com/jefflgaol/Install-Packages-Jetson-ARM-Family You might want to have a look.

2 Likes

I updated @jefflgaol script to LLVM-9.0.1 and successfully installed on Nano.

@ben.p can you please share Numba install? I’ve tried sudo pip3 install numba but ran into errors.