nvarguscamerasrc force mode 1

Hi,

im using a jetson nano and a 8 megapixels Waveshare IMX219-120 camera.

if i run:

gst-launch-1.0 nvarguscamerasrc ! 'video/x-raw(memory:NVMM), width=3280, height=1848, framerate=28/1, format=NV12'  !

the camera or gstreamer decide to use mode 0 with:

GST_ARGUS: Running with following settings:
   Camera index = 0 
   Camera mode  = 0 
   Output Stream W = 3264 H = 2464 
   seconds to Run    = 0 
   Frame Rate = 21,000000

but i need mode 1 with 28/1 fps. I also tried:

gst-inspect-1.0 nvarguscamerasrc

but can’t find any parameter to set the right mode. i tried different resolutions with success, but width=3280, height=1848, framerate=28/1 does not work

best regards Martin

Based on R32.2 imx219 dts file mode 1 is 3264 x 1848 @28 FPS, so try with width=3264 and height=1848.

hello m.fischer,

may I know which JetPack release you’re working with?

please note that the resolution has changed due to hardware limitation.
you should also check below sensor device tree for reference,
for example,

[i]$l4t-r32.2/kernel_src/hardware/nvidia/platform/t210/porg/kernel-dts/porg-platforms/tegra210-camera-rbpcv2-imx219.dtsi

                                mode1 { /* IMX219_MODE_3264x1848_28FPS */

                                        active_w = "3264";
                                        active_h = "1848";
                                        default_framerate = "28000000"; /* 28.0 fps */
[/i]

typos, typos everywhere! as jas-mx said:

gst-launch-1.0 nvarguscamerasrc ! 'video/x-raw(memory:NVMM), width=3264, height=1848, framerate=28/1, format=NV12' !

works fine!

But it would be nice if we can use something like this:

gst-launch-1.0 nvarguscamerasrc mode=1 ! 'video/x-raw(memory:NVMM), format=NV12' !

best regards Martin