Nvarguscamerasrc not calling PowerServiceHwVic::cleanupResources

I am using an 8MP stereo camera array hat with two IMX 219’s connected through the CSI port and when I open a pipeline with this source it will not reopen without cycling the power on the camera. I never see the call for PowerServiceHwVic::cleanupResources happening at the end of closing any pipeline either.
Here is a link to the camera Arducam 8MP Synchronized Stereo Camera Bundle Kit for Jetson Nano
I have followed their instructions and asked for their help also with no reply. I tried other version of Jetpack also.

If you want any debug information please leave instructions for how to get the information.

Sorry for the late response, have you received the suggestion from Arducam?
Any result to share? Thanks

No it seems they are probably out for the holiday. Only result I can see is the argus-daemon crashes because it’s left in a bad state.

hello preston.hackett,

may I know which JetPack release you’re using,
furthermore,
please also see Approaches for Validating and Testing the V4L2 Driver.
you may have simplify commands to test the camera streaming for issue narrow down.
thanks

I am using the current version of Jetpack I forget the exact version number I have also tried the latest revision on another device and also rolled back versions. Other approaches I have tried were with the cabling to see if it was a problem with hardware which I have ruled out. I will download and extract those files for the multimedia API later and check those out I am not familiar with that process. I have run those gst commands and there wasn’t any change the camera will start once but then will not restart. I will let you know what I find out let me know if you have any other suggestions.

please also test with V4L2 IOCTL directly, using v4l2-ctl to verify basic functionality during sensor bring-up.

1 Like

Yes I have tried those troubleshooting steps before and again this time. I am using the tegra-video driver imx219 for the camera I showed. The device capabilities and formats all seem fine. The recording a raw video command even works only the first time also. The second time it just hangs and doesn’t record anything.

We can blame the hardware and I can buy another but if the problem is the same can this be solved?

I have sent another email to Arducam about this hopefully someone will respond to let me know if they already know what this problem is.

hello preston.hackett,

please also share the kernel logs (i.e. $ dmesg) to understand the root-cause.

dmesglog.txt (55.7 KB)
Here is the dmesg

hello preston.hackett,

there’re sync point timeout failures, which means the camera devices is no response.

[   76.722626] video4linux video0: frame start syncpt timeout!0
[   76.930493] video4linux video0: frame start syncpt timeout!0
[   77.138867] video4linux video0: frame start syncpt timeout!0
[   77.354542] video4linux video0: frame start syncpt timeout!0

may I know which JetPack release you’re working with? you should check $ cat /etc/nv_tegra_release for confirmation.

R32 Revision 6.1, I did some searching and found that with this condition that it is caused normally because - frame sync timeout issue due to CSI clocks not properly set for corresponding blocks. But I am not familiar with how to solve this so I am still searching to see if this is correct.

This condition occurs when I stop the camera and try to restart it.

I have tried Revision 6.3 also already and the version prior to 6.1

hello preston.hackett,

what do you mean Revision 6.3; please visit the JetPack Archive. there’s no such release

4.6 Revision 3 in the Jetpack SDK

I have a new bit of information. When I run v4l2-ctl -I to query the camera it says camera0 no power. However the camera is powered and I can make it work if I unplug the camera and plug it back in. But the status always says no power when using this camera.

hello preston.hackett,

is your use-case related to hot-plug the camera device?
please ensure you had connect/disconnect the camera device when power-off.

No it is not related to hot plug. Just it works once you un plug it and plug it back it again. Even while the jetson is running after the device hangs.