No Cameras Available(detected) on my Jetson kit

Hello, I just got a Jetson developer kit from my team and I am trying to capture and record a video using the ArduCam camera.
The problem is, when I tested it with my team, the camera works fine, so is the video recording. But this morning, I unplugged the original connection wire, which connects the kit and the camera board, and tried to replace it with a longer wire. However, after I inserted the wire, the working code did not bring up the camera view anymore. Instead, it generated an error, saying No cameras available.
This is the code I used to check if the camera works: DISPLAY=:0.0 gst-launch-1.0 nvarguscamerasrc ! ‘video/x-raw(memory:NVMM),width=3280,height=2464,format=NV12,framerate=10/1’ ! nvvidconv ! autovideosink -e
I did check dmesg, which gives me this feedback:
[ 6.713953] gpio-397 (camera-control-output-low): hogged as output/low
[ 6.720726] gpio-486 (camera-control-output-low): hogged as output/low

I have tried to switch to the original wire, which still says camera not available. Based on the previous success, the camera is compatible, so is the camera board and the connection wire.
At the moment, I am still pretty new to Jeston kit. Could anybody help me with this please? Thank you.

For the additional information, here is the message I got after I input the working code:

Setting pipeline to PAUSED …
Pipeline is live and does not need PREROLL …
Setting pipeline to PLAYING …
New clock: GstSystemClock
Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp, execute:751 No cameras available
WARNING: from element /GstPipeline:pipeline0/GstAutoVideoSink:autovideosink0/GstXvImageSink:autovideosink0-actual-sink-xvimage: Pipeline construction is invalid, please add queues.
Additional debug info:
gstbasesink.c(1209): gst_base_sink_query_latency (): /GstPipeline:pipeline0/GstAutoVideoSink:autovideosink0/GstXvImageSink:autovideosink0-actual-sink-xvimage:
Not enough buffering available for the processing deadline of 0:00:00.015000000, add enough queues to buffer 0:00:00.015000000 additional data. Shortening processing latency to 0:00:00.000000000.
Got EOS from element “pipeline0”.
Execution ended after 0:00:00.003749529
Setting pipeline to NULL …
Freeing pipeline …

hello butcherawm,

may I confirm the Jetpack release version you’re now working with.

please also note that…
CSI it is susceptible to multiple factors, such as… trace length, temperature, wear of the components, and MIPI speeds…etc
it should be necessary to update device tree settings (especially the pixel clock) due to longer wire.

besides,
how you unplugged/plug the wire, did you hot-swapping the camera connector?
if yes, you may also give it a try to restart camera service, which may restore the original functionality.
for instance,
$ sudo pkill nvargus-daemon
$ sudo systemctl start nvargus-daemon

Hello JerryChang,

thanks for your reply. The installed version is as follows:

nvidia-l4t-core	35.3.1-20230319081403

Before I realized I should unplug/plug the wire when off, I did hot-swap the connection for a few times.
Though I have restarted the camera device which still does not work for me.
I have tried different combinations of connection wires and lens, none of which worked. Now I am a bit concerned if it could be the problem the of my Jetson kit, for example, the CSI port.

hello butcherawm,

please be sure it’s not caused by a hardware damage.
you may probe the MIPI signaling to check there’re valid packets on CSI channel for confirmation.

please also note that, JP-5.1.1/r35.3.1 was not a stable release version.
as you can see…
we’ve several camera bug fixes to address stability issue.
Topic 243051, [Argus] camera stability and error resiliency bug fixes.
Topic 268519, [Argus] pre-built update to resolve memory corruption within libnvargus.so

could you please apply above pre-built update for testing.
or… please moving to the latest JP-5.1.3/r35.5.0 release version if that’s feasible.