nvcc cannot find a supported cl version

Hello,
I run on Windows 7 64 bits and I use Visual Studio 2010.
I tried to compile my first .cu program with nvcc (3.1) and it gave the following:
“nvcc cannot find a supported cl version. Only MSVC 8.0 and MSVC 9.0 are supported”

Is it possible to have an idea of when nvcc will support MSVC 10.0?
(I am about to buy a Tesla C2070 to accelerate my research calculations, but then what if I cannot
even compile to get acquainted with CUDA on my current GeForce 9800 card? :confused: )

In the meantime, is there an easy way to get around this (only with command line operations please,
I never use Visual Studio IDE)?

One more thing, my PC’s motherboard is the Gigabyte X58A UD7 rev.1.0 and a friend told me that
I will have to update the BIOS to rev.2.0 to be able to use a C2050 or C2070 on it.
Have you heard of that? The triky thing is that BIOS rev.2.0 for that card is still Beta (for how long?..)

Of course, the simplest solution for me would be to wait a few months until all these problems
are settled before buying the C2070…

Still, I would be very grateful if you could advise me on the matter.
Many thanks in advance,
Manuel