nvcc compile error nvopencc error

I am trying to compile a program with nvcc.

I get through it OK, until the nvopencc part of the compile:

#$ nvopencc -TARG:sm_10 -m32 “C:\DOCUME~1\CHUCKI~1.000\LOCALS~1\Temp/tmpxft_000
00c10_00000000-9_test3.cpp3.i” -o “C:\DOCUME~1\CHUCKI~1.000\LOCALS~1\Temp/tmpxf

at which point I get an error screen.

The error is:

AppName: nvopencc.exe AppVer: ModName: msvcrt.dll
ModVer: 7.0.2600.2180 Offset: 000378c0

and finally, on the output

nvcc error : ‘nvopencc’ died with status 0xC0000005 (ACCESS_VIOLATION)

–error 0xc0000005 –

The file C:\DOCUME~1\CHUCKI~1.000\LOCALS~1\Temp/tmpxft_000
00c10_00000000-9_test3.cpp3.i Doesn’t seem to exist at the time of the error.


i met the same error~~
And I change the paramenter from local to shared memory


Which parameter did you change? Did it fix the problem.

Running nvopencc without any parameters at all produces the same error for me (2.0 beta) 1.1 however seems fine.

Never seen nvcc spit out a C0000005–can you provide a test case? Thanks.

First, in the GPU code, when I change the local memory into shared memory solved the error.