nvcc could not open input file nvcc dies on something in Temp

hello all. I am trying to compile a simple CUDA application in VS2005 under XP. I used the 1.2 version of the wizard to make the CUDA project, and am trying to compile before I have modified any part of it. Here is the full message:

nvcc fatal : Could not open input file C:\Documents and Settings\Tialis\Local Settings\Temp/tmpxft_00000990_00000000-1

I have used the wizard successfully on other machines, I only get the error on this one…

Anyone have any thoughts?

Thanks,
T

I am getting the same problem. This happens whenever I try to build an example from the SDK. I am using VC8 on windows XP.

Anyone got any ideas?

Can you use the project from the SDK? Try it first…

administrator permission?

1.do you have developer permission?

how would i check? I can certainly build and debug C++ using Visual Studio.

I have administrator privileges on my PC, its running windows xp.

I can get it all to work on my home computer.

I have the same problem. I can run the projects from the SDK and have the administrator permission. But fail to build, with the error

nvcc fatal : Could not open input file C:\DOCUME~1\LOCALS~1\Temp/tmpxft_000007fc_00000000-1

Similar problem for me, with the same error message.
I have two computers, one under vista and the other one with win 2000. All CUDA driver, toolkit,
and SDK were properly installed on the vista computer, and everything works fine, even home-made projects
not belonging to the SDK.

The problem arises on win 2000. As it is not explicitely supported, and as I do not have permission to
install the SDK on the win 2000 (xp version of toolkit could be installed without problems though), I simply copied the installed files from vista to win 2000, and defined the correct environment variables. The error described in the above messages appears when I compile a .cu file.

I checked into the mentionned /Temp directory. While compiling, visual studio output some files there, but the required file
specified in the error message is not output. And I have permission to create, modified, and delete files in that directory.

Any updates, any idea?

S.G.

I have the identical problem.

Can easily compile using nvcc on one machine / cannot compile on my laptop.

Configurations look very similar and I have admin rights on both machines.

Changing the TEMP Environment Variable does not solve problem either.

Adding the -keep option does nothing.

3DBold,

do you use Visual Studio?

The documentation on nvcc says that some temporary files are created. I’ve opened the /temp directory

while compiling (with Visual Studio) and nothing is written in it when I compile a .cu file, while

some stuff are written if I compile a .cpp. It looks like the file is written somewhere else and the

next step in compilation cannot find it, that’s probably why the -keep does nothing.

By the way, how do you specify the option -keep? Do you run in command line?

If it was indeed kept, maybe we can find it with a file search.

s.g.

Same problem here. I am using VS2008 and CUDA 2.2.

According to Sysinternals File Monitor, the …00000000-1 file is never created in the temp directory. A …00000000, a …00000000-1.bat and …00000000-2.bat file are created successfully by nvcc, and deleted afterwards. So the problem seems not to be related to not having access to the temp directory or something like that.

At this moment I don’t see any solution, but I’ll try to figure out more. Hope sombody else will find the answer to this problem.

AlexP

I’ve got the same problem. Compiling examples from SDK.
nvcc fatal : Could not open input file C:\Users\MS\AppData\Local\Temp/tmpxft_00000dec_00000000-1
Same result when i try to compile from console.
Windows Vista, VS2k8(9.0), CUDA2.2, 9800GT
I hope if someone will find the solution, he’s gonna post it here. I will if I find out how to manage it.

I have installed previous version of Visual Studio (2005), and set the C compiler path in nvcc.profile for the cl.exe from vs2005. Now it works fine, cuda files are compiling both from console and from vs. I still don’t know why it doesn;t work with vs2008 on my computer.

I have the same problem in visual studio2005 and cuda 2.2 on windows xp.
I solved it by replacing the environmental varialble “TEMP=%USERPROFILE%\Local Settings\Temp” by “TEMP=%SystemRoot%\TEMP”.

I have this problem too, and I’m keen to hear an answer. I’m using Vista, and I don’t have another computer on which it is working.
There’s a thread about the same problem in the Vista section which I’ve written about a minor discovery:
http://forums.nvidia.com/index.php?showtopic=91131

I discovered the source of the problem, which I posted about in the thread linked above.

Just as a quick note - what worked for me was to remove all quotation marks from the PATH environment variable.
It seems this caused the error message in my case…

Yes, removing quotations from my PATH also solved the problem. It seems from previous posts however that this problem can stem from multiple sources.