NvDsInterfaceExt missing

OS Ubuntu 2204

Docker version 26.1.4, build 5650f9b

docker-compose version 1.29.2, build unknown

NVIDIA-SMI 555.42.02

CUDA Version: 12.5

Cuda compilation tools, release 12.5, V12.5.40
Build cuda_12.5.r12.5/compiler.34177558_0

rivermax_ubuntu2204_1.50.7

Deepstream 7.0.0

Graph Composer 4.0.0

I am using Graph Composer and I get missing NvDsInterfaceExt for all my graphs.

The sample graph AudioTest3sony.yaml is attached.
AudioTest3sony.yaml.txt (2.0 KB)

This is the error which I get:

2024-07-02 18:45:00,017 - Registry - ERROR - No matching variant found for extension: NvDsInterfaceExt version: 1.5.0

ERROR:No matching variant found for extension: NvDsInterfaceExt version: 1.5.0

2024-07-02 18:45:00,017 - Registry - ERROR - Requested target configuration arch: x86_64 os: linux distribution: ubuntu_22.04 cuda: 12.2 cudnn: 8.9.2 tensorrt: 8.6.1 deepstream: 6.4 vpi: 2.3.1

ERROR:Requested target configuration arch: x86_64 os: linux distribution: ubuntu_22.04 cuda: 12.2 cudnn: 8.9.2 tensorrt: 8.6.1 deepstream: 6.4 vpi: 2.3.1

2024-07-02 18:45:00,017 - Registry - ERROR - Extension variants found ['arch: aarch64 os: linux distribution: ubuntu_22.04 deepstream: 7.0 ', 'arch: x86_64 os: linux distribution: ubuntu_22.04 deepstream: 7.0 ']

ERROR:Extension variants found ['arch: aarch64 os: linux distribution: ubuntu_22.04 deepstream: 7.0 ', 'arch: x86_64 os: linux distribution: ubuntu_22.04 deepstream: 7.0 ']

2024-07-02 18:45:00,017 - Registry - ERROR - Failed to find extensions for manifest from graphs [‘/tmp/gxf_137014313660432/MyGraph4.yaml’]

ERROR:Failed to find extensions for manifest from graphs [‘/tmp/gxf_137014313660432/MyGraph4.yaml’]

2024-07-02 18:45:00.019 INFO gxf/gxe/gxe.cpp@183: Creating context

2024-07-02 18:45:00.019 ERROR gxf/gxe/gxe.cpp@255: LoadExtensionManifest Error: GXF_FAILURE

It thinks it is there:

bill@H4M5ibc:~$ registry extn list -n NvDsInterfaceExt
NvDsInterfaceExt : Interfaces and data components for DeepStream

Trying to sync shows this:

bill@H4M5ibc:~$ registry repo sync -n ngc-public

2024-07-02 19:10:31,174 - Registry - INFO - Syncing repo ngc-public …

2024-07-02 19:10:31,682 - Registry - INFO - 46 extensions found

2024-07-02 19:10:34,740 - Registry - INFO - Syncing extension NvDsBaseExt version 1.4.1

2024-07-02 19:10:34,744 - Registry - INFO - Syncing extension NvDsBaseExt version 1.2.0

2024-07-02 19:10:34,747 - Registry - INFO - Syncing extension NvDsBaseExt version 1.4.0

2024-07-02 19:10:36,197 - Registry - INFO - Syncing extension NvDsInferenceUtilsExt version 1.0.0

2024-07-02 19:10:36,214 - Registry - INFO - Syncing extension NvDsInterfaceExt version 1.5.0

2024-07-02 19:10:36,227 - Registry - INFO - Syncing extension NvDsInterfaceExt version 1.4.0

2024-07-02 19:10:36,240 - Registry - INFO - Syncing extension NvDsInterfaceExt version 1.1.0

2024-07-02 19:10:36,242 - Registry - INFO - Syncing extension NvDsInterfaceExt version 1.3.0

2024-07-02 19:10:36,447 - Registry - INFO - Syncing extension NvDsInterfaceExt version 1.0.0

2024-07-02 19:10:36,573 - Registry - INFO - Syncing extension NvDsMuxDemuxExt version 1.5.0

2024-07-02 19:10:51,863 - Registry - INFO - Syncing extension VideoEncoderIOExtension version 1.1.0

2024-07-02 19:10:53,499 - Registry - INFO - Updating database …

2024-07-02 19:11:52,730 - Registry - WARNING - Some extensions failed to sync. Check logs at /tmp/nvgraph_registry.log
nvgraph_registry.log (988.4 KB)

Repository synced

bill@H4M5ibc:~$

nvgraph_registry.log shows:

2024-07-02 19:11:02,753 - Registry - DEBUG - Skipping extension NvDsInferenceUtilsExt version 1.4.0

2024-07-02 19:11:02,769 - Registry - DEBUG - Removing stale extension NvDsInterfaceExt from repo ngc-public

2024-07-02 19:11:02,769 - Registry - DEBUG - Removing extension from cache ExtensionRecord(name=‘NvDsInterfaceExt’, version=‘1.5.0’, uuid=‘f787f50d-9004-4e85-88b9-1ed1894257f2’)

2024-07-02 19:11:03,945 - Registry - DEBUG - Incompatible gxf core version

2024-07-02 19:11:03,945 - Registry - DEBUG - Registry gxf core version: 4.0.0 Extension gxf core version: 2.4.2

2024-07-02 19:11:03,945 - Registry - DEBUG - Skipping extension NvDsBaseExt version 1.0.0

2024-07-02 19:11:03,953 - Registry - DEBUG - Incompatible gxf core version

I tried

bill@H4M5ibc:~$ registry extn import interface -n NvDsInterfaceExt -s 1.5.0 -d ext

2024-07-02 19:25:18,405 - Registry - INFO - Importing extension interface …

Extension interface imported successfully

but I don’t know what to use for directory?

How do I fix this?

it looks like I need to fix gxf core version

Have you tried the deepstream-test1 sample graph? can it work in your environment?

Yes. That works but doesn.t use that item.

How does the compiled test sample relate to Graph Composer?

registry repo sync -n ngc-public fails because:
Removing extension from cache ExtensionRecord(name=‘NvDsInterfaceExt’, version=‘1.5.0’
and
DEBUG - Incompatible gxf core version
and
DEBUG - Registry gxf core version: 4.0.0 Extension gxf core version: 2.4.2

How do I get ‘NvDsInterfaceExt’ built with the correct gxf core version to be accepted by registry repo sync -n ngc-public

No. It doesn’t work in Composer. Same problem.

DEBUG:Dependent extensions required [‘NvDsInterfaceExt:1.5.0’, ‘StandardExtension:2.5.0’, ‘MultimediaExtension:2.5.0’, ‘NvDsBaseExt:1.5.0’, ‘HttpExtension:0.4.0’, ‘NvDsSourceExt:1.5.0’, ‘NvDsMuxDemuxExt:1.5.0’, ‘NvDsInferenceExt:1.5.0’, ‘NvDsSampleModelsExt:1.5.0’, ‘NvDsOutputSinkExt:1.5.0’, ‘NvDsVisualizationExt:1.5.0’, ‘NvDsInferenceUtilsExt:1.5.0’]
DEBUG:Found a close match TargetConfig(platform=PlatformConfig(arch=‘x86_64’, os=‘linux’, distribution=‘ubuntu_22.04’), compute=ComputeConfig(cuda=None, cudnn=None, tensorrt=None, deepstream=‘7.0’, triton=None, vpi=None))
2024-07-07 15:43:38,872 - Registry - ERROR - No matching variant found for extension: NvDsInterfaceExt version: 1.5.0
ERROR:No matching variant found for extension: NvDsInterfaceExt version: 1.5.0
2024-07-07 15:43:38,872 - Registry - ERROR - Requested target configuration arch: x86_64 os: linux distribution: ubuntu_22.04 cuda: 12.2 cudnn: 8.9.2 tensorrt: 8.6.1 deepstream: 6.4 vpi: 2.3.1
ERROR:Requested target configuration arch: x86_64 os: linux distribution: ubuntu_22.04 cuda: 12.2 cudnn: 8.9.2 tensorrt: 8.6.1 deepstream: 6.4 vpi: 2.3.1
2024-07-07 15:43:38,872 - Registry - ERROR - Extension variants found ['arch: aarch64 os: linux distribution: ubuntu_22.04 deepstream: 7.0 ', 'arch: x86_64 os: linux distribution: ubuntu_22.04 deepstream: 7.0 ']
ERROR:Extension variants found [‘arch: aarch64 os: linux distribution: ubuntu_22.04 deepstream: 7.0 ‘, ‘arch: x86_64 os: linux distribution: ubuntu_22.04 deepstream: 7.0 ‘]
2024-07-07 15:43:38,872 - Registry - ERROR - Failed to find extensions for manifest from graphs [’/tmp/gxf_140168395714096/deepstream-test1.yaml’]
ERROR:Failed to find extensions for manifest from graphs [’/tmp/gxf_140168395714096/deepstream-test1.yaml’]
2024-07-07 15:43:38.876 INFO gxf/gxe/gxe.cpp@183: Creating context
2024-07-07 15:43:38.877 ERROR gxf/gxe/gxe.cpp@255: LoadExtensionManifest Error: GXF_FAILURE

Yes: I did Registry ngc-public Sync Repo

2024-07-07 15:55:53,683 - Registry - INFO - Syncing extension NvDsInterfaceExt version 1.1.0
INFO:Syncing extension NvDsInterfaceExt version 1.5.0
DEBUG:Downloading file /home/bill/.cache/nvgraph_registry/NvDsDewarperExt/1.3.0/1.3.0-linux-aarch64-ubuntu_20.04-ds-6.3/target.yaml
INFO:Syncing extension NvDsInterfaceExt version 1.1.0
2024-07-07 15:55:53,694 - Registry - INFO - Syncing extension NvDsInterfaceExt version 1.0.0
2024-07-07 15:55:53,695 - Registry - INFO - Syncing extension NvDsInterfaceExt version 1.3.0
INFO:Syncing extension NvDsInterfaceExt version 1.0.0
INFO:Syncing extension NvDsInterfaceExt version 1.3.0

DEBUG:Dependent extensions required [‘NvDsInterfaceExt:1.5.0’, ‘StandardExtension:2.5.0’, ‘MultimediaExtension:2.5.0’, ‘NvDsBaseExt:1.5.0’, ‘HttpExtension:0.4.0’, ‘NvDsSourceExt:1.5.0’, ‘NvDsMuxDemuxExt:1.5.0’, ‘NvDsInferenceExt:1.5.0’, ‘NvDsSampleModelsExt:1.5.0’, ‘NvDsOutputSinkExt:1.5.0’, ‘NvDsVisualizationExt:1.5.0’, ‘NvDsInferenceUtilsExt:1.5.0’]
DEBUG:Found a close match TargetConfig(platform=PlatformConfig(arch=‘x86_64’, os=‘linux’, distribution=‘ubuntu_22.04’), compute=ComputeConfig(cuda=None, cudnn=None, tensorrt=None, deepstream=‘7.0’, triton=None, vpi=None))
2024-07-07 15:43:38,872 - Registry - ERROR - No matching variant found for extension: NvDsInterfaceExt version: 1.5.0
ERROR:No matching variant found for extension: NvDsInterfaceExt version: 1.5.0
2024-07-07 15:43:38,872 - Registry - ERROR - Requested target configuration arch: x86_64 os: linux distribution: ubuntu_22.04 cuda: 12.2 cudnn: 8.9.2 tensorrt: 8.6.1 deepstream: 6.4 vpi: 2.3.1
ERROR:Requested target configuration arch: x86_64 os: linux distribution: ubuntu_22.04 cuda: 12.2 cudnn: 8.9.2 tensorrt: 8.6.1 deepstream: 6.4 vpi: 2.3.1
2024-07-07 15:43:38,872 - Registry - ERROR - Extension variants found ['arch: aarch64 os: linux distribution: ubuntu_22.04 deepstream: 7.0 ', 'arch: x86_64 os: linux distribution: ubuntu_22.04 deepstream: 7.0 ']
ERROR:Extension variants found [‘arch: aarch64 os: linux distribution: ubuntu_22.04 deepstream: 7.0 ‘, ‘arch: x86_64 os: linux distribution: ubuntu_22.04 deepstream: 7.0 ‘]
2024-07-07 15:43:38,872 - Registry - ERROR - Failed to find extensions for manifest from graphs [’/tmp/gxf_140168395714096/deepstream-test1.yaml’]
ERROR:Failed to find extensions for manifest from graphs [’/tmp/gxf_140168395714096/deepstream-test1.yaml’]
2024-07-07 15:43:38.876 INFO gxf/gxe/gxe.cpp@183: Creating context
2024-07-07 15:43:38.877 ERROR gxf/gxe/gxe.cpp@255: LoadExtensionManifest Error: GXF_FAILURE
DEBUG:Incompatible gxf core version
DEBUG:Registry gxf core version: 4.0.0 Extension gxf core version: 3.1.0

2024-07-07 15:57:08,851 - Registry - WARNING - Some extensions failed to sync. Check logs at /tmp/nvgraph_registry.log
WARNING:Some extensions failed to sync. Check logs at /tmp/nvgraph_registry.log

I can’t reproduce the failure you post here. Have you install the DeepStream 7.0 correctly before you install Graph Composer?

I tried a new install on a new system:

bill@H4Mdq:~/Downloads$ sudo apt install ./deepstream-7.0_7.0.0-1_amd64.deb
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
Note, selecting ‘deepstream-7.0’ instead of ‘./deepstream-7.0_7.0.0-1_amd64.deb’
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
deepstream-7.0 : Depends: libnvinfer8 (>= 8.0.0) but it is not installable
Depends: libnvinfer-dev (>= 8.0.0) but it is not installable
Depends: libnvparsers8 (>= 8.0.0) but it is not installable
Depends: libnvparsers-dev (>= 8.0.0) but it is not installable
Depends: libnvonnxparsers8 (>= 8.0.0) but it is not installable
Depends: libnvonnxparsers-dev (>= 8.0.0) but it is not installable
Depends: libnvinfer-plugin8 (>= 8.0.0) but it is not installable
Depends: libnvinfer-plugin-dev (>= 8.0.0) but it is not installable
E: Unable to correct problems, you have held broken packages.
bill@H4Mdq:~/Downloads$

Previously this worked but which repository needs to be loaded?

bill@H4Mdq:~/Downloads/glib/build$ version=“8.6.1.6-1+cuda12.0”
bill@H4Mdq:~/Downloads/glib/build$ sudo apt-get install graphsurgeon-tf=${version} libnvinfer-bin=${version} libnvinfer-dev=${version} libnvinfer-dispatch-dev=${version} libnvinfer-dispatch8=${version} libnvinfer-headers-dev=${version} libnvinfer-headers-plugin-dev=${version} libnvinfer-lean-dev=${version} libnvinfer-lean8=${version} libnvinfer-plugin-dev=${version} libnvinfer-plugin8=${version} libnvinfer-samples=${version} libnvinfer-vc-plugin-dev=${version} libnvinfer-vc-plugin8=${version} libnvinfer8=${version} libnvonnxparsers-dev=${version} libnvonnxparsers8=${version} libnvparsers-dev=${version} libnvparsers8=${version} onnx-graphsurgeon=${version} python3-libnvinfer-dev=${version} python3-libnvinfer-dispatch=${version} python3-libnvinfer-lean=${version} python3-libnvinfer=${version} tensorrt-dev=${version} tensorrt-libs=${version} tensorrt=${version} uff-converter-tf=${version}
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
E: Unable to locate package graphsurgeon-tf
E: Unable to locate package libnvinfer-bin
E: Unable to locate package libnvinfer-dev
E: Unable to locate package libnvinfer-dispatch-dev
E: Unable to locate package libnvinfer-dispatch8
E: Unable to locate package libnvinfer-headers-dev
E: Unable to locate package libnvinfer-headers-plugin-dev
E: Unable to locate package libnvinfer-lean-dev
E: Unable to locate package libnvinfer-lean8
E: Unable to locate package libnvinfer-plugin-dev
E: Unable to locate package libnvinfer-plugin8
E: Unable to locate package libnvinfer-samples
E: Unable to locate package libnvinfer-vc-plugin-dev
E: Unable to locate package libnvinfer-vc-plugin8
E: Unable to locate package libnvinfer8
E: Unable to locate package libnvonnxparsers-dev
E: Unable to locate package libnvonnxparsers8
E: Unable to locate package libnvparsers-dev
E: Unable to locate package libnvparsers8
E: Unable to locate package onnx-graphsurgeon
E: Unable to locate package python3-libnvinfer-dev
E: Unable to locate package python3-libnvinfer-dispatch
E: Unable to locate package python3-libnvinfer-lean
E: Unable to locate package python3-libnvinfer
E: Unable to locate package tensorrt-dev
E: Unable to locate package tensorrt-libs
E: Unable to locate package tensorrt
E: Unable to locate package uff-converter-tf
bill@H4Mdq:~/Downloads/glib/build$

If you install the DeepStream and Graph Composer by yourself, please follow the Installation — DeepStream documentation 6.4 documentation exactly.

Thanks for the reply. I did that. Same issue.

DEBUG:Dependent extensions required [‘NvDsInterfaceExt:1.5.0’, ‘StandardExtension:2.5.0’, ‘MultimediaExtension:2.5.0’, ‘NvDsBaseExt:1.5.0’, ‘NvDsOutputSinkExt:1.5.0’, ‘NvDsCloudMsgExt:1.5.0’, ‘HttpExtension:0.4.0’, ‘NvDsSourceExt:1.5.0’, ‘DeepStreamExtensionTest:1.5.0’, ‘NvDsTranscodeExt:1.5.0’, ‘NvDsConverterExt:1.5.0’]
DEBUG:Found a close match TargetConfig(platform=PlatformConfig(arch=‘x86_64’, os=‘linux’, distribution=‘ubuntu_22.04’), compute=ComputeConfig(cuda=None, cudnn=None, tensorrt=None, deepstream=‘7.0’, triton=None, vpi=None))
2024-07-11 08:23:08,045 - Registry - ERROR - No matching variant found for extension: NvDsInterfaceExt version: 1.5.0
ERROR:No matching variant found for extension: NvDsInterfaceExt version: 1.5.0
2024-07-11 08:23:08,045 - Registry - ERROR - Requested target configuration arch: x86_64 os: linux distribution: ubuntu_22.04 cuda: 12.2 cudnn: 8.9.2 tensorrt: 8.6.1 deepstream: 6.4 vpi: 2.3.1
ERROR:Requested target configuration arch: x86_64 os: linux distribution: ubuntu_22.04 cuda: 12.2 cudnn: 8.9.2 tensorrt: 8.6.1 deepstream: 6.4 vpi: 2.3.1
2024-07-11 08:23:08,045 - Registry - ERROR - Extension variants found ['arch: aarch64 os: linux distribution: ubuntu_22.04 deepstream: 7.0 ', 'arch: x86_64 os: linux distribution: ubuntu_22.04 deepstream: 7.0 ']
ERROR:Extension variants found [‘arch: aarch64 os: linux distribution: ubuntu_22.04 deepstream: 7.0 ‘, ‘arch: x86_64 os: linux distribution: ubuntu_22.04 deepstream: 7.0 ‘]
2024-07-11 08:23:08,045 - Registry - ERROR - Failed to find extensions for manifest from graphs [’/tmp/gxf_140346869235632/Player1.yaml’]
ERROR:Failed to find extensions for manifest from graphs [’/tmp/gxf_140346869235632/Player1.yaml’]
2024-07-11 08:23:08.057 INFO gxf/gxe/gxe.cpp@183: Creating context
2024-07-11 08:23:08.058 ERROR gxf/gxe/gxe.cpp@255: LoadExtensionManifest Error: GXF_FAILURE

Where does NvDsInterfaceExt version: 1.5.0 live? Which folder?