NVENC vbr_hq useBframesAsRef and interlace

Hello.
I have issue with transcoding H264 in vbrhq with useBframesAsRef and interlaced mode.
After running command:

ffmpeg -hwaccel cuvid -vcodec h264_cuvid -i 00046\ AAC+MPEG+LPCM.ts -vcodec h264_nvenc -vb 5M -rc vbr_hq -refs 4 -bf 4 -b_ref_mode middle -flags +ilme+ildct -acodec copy test.ts

the encoder is hangs, and nothing happens.
But if I change
vbr_hq to vbr
or remove -b_ref_mode middle
or remove -flags +ilme+ildct
all works well.

Does NVIDIA support simultaneously: Variable bitrate high quality mode (-rc vbrhq) + Use B frames as references (-b_ref_mode middle) + Interlaced mode (-flags +ilme+ildct) ?

I have NVIDIA 1080 GPU, Linux with NVIDIA Driver 396.54, cuda 9.2.148, and latest ffmpeg from https://git.ffmpeg.org/ffmpeg.git
Link on my video file https://www.dropbox.com/s/mlgbi58wf3qo0bq/00046%20AAC%2BMPEG%2BLPCM.ts?dl=0

Thanks.

Hi seregajsv,

We are already aware of this issue and the issue is under investigation.

Thanks,
Ryan Park

Still issue happens on Linux drivers 410.73

To add to thread starter’s post, even with -rc vbr, the output is corrupted, many errors in encoding. So probably that’s why -rc vbr_hq crashes, it reads corrupted data on 2nd pass.

Also using -b_ref_mode middle even on progressive output that works fine, ffmpeg keeps reporting issues about DTS, which are not shown with -b_ref_mode none, issues like the following:
[mpegts @ 0x55a776ae4d40] Invalid DTS: 662400 PTS: 658800 in output stream 0:0, replacing by guess
[mpegts @ 0x55a776ae4d40] Invalid DTS: 687600 PTS: 684000 in output stream 0:0, replacing by guess
[mpegts @ 0x55a776ae4d40] Invalid DTS: 702000 PTS: 698400 in output stream 0:0, replacing by guess
which keep running all the time.

Problem still exists on Linux drivers 415.18

Problem still exists on Linux drivers 418.56

Anyone from nvidia, are you going to ever fix this? You disabled interlaced encoding in Turing, at least support it right on Pascal. There are many use cases that still need interlaced encoding.