Nvidi driver installed but graphic card not detected


My computer is under Ubuntu 22.04 (well Linux Mint, 21.1, but it’s the same) and has an Nvidia T600 GPU.
My kernel is 6.1.0-x64v3+.
My secure boot is disabled.
My installed driver is nvidia-driver-535 and should support Nvidia T600.

Nvidia X server settings doesn’t show any graphic card.
Running prime-select query displays


Running lspci -vnnn | perl -lne 'print if /^\d+\:.+(\[\S+\:\S+\])/' | grep VGA displays

00:02.0 VGA compatible controller [0300]: Intel Corporation Alder Lake-P Integrated Graphics Controller [8086:4626] (rev 0c) (prog-if 00 [VGA controller])

Below my nvidia bug report.
nvidia-bug-report.log.gz (95.2 KB)

Very similar topic : Video-nvidia driver is not detecting my graphic card

Thanks a lot for your help !

Don’t know if it’s related but I don’t have the Discrete graphic option in BIOS, so I’m staying on the Hybrid option

@generix sorry to identify you, but I saw you started answering the problem on the mentioned link (Video-nvidia driver is not detecting my graphic card), may you please help me ?
Thanks a lot !
Here is the result of

~$ grep nvidia /etc/modprobe.d/* /lib/modprobe.d/*

/etc/modprobe.d/blacklist-framebuffer.conf:blacklist nvidiafb
/etc/modprobe.d/nvidia-graphics-drivers-kms.conf:# This file was generated by nvidia-driver-525
/etc/modprobe.d/nvidia-graphics-drivers-kms.conf:options nvidia-drm modeset=1
/lib/modprobe.d/blacklist-nvidia.conf:# This file was generated by nvidia-prime
/lib/modprobe.d/blacklist-nvidia.conf:blacklist nvidia
/lib/modprobe.d/blacklist-nvidia.conf:blacklist nvidia-drm
/lib/modprobe.d/blacklist-nvidia.conf:blacklist nvidia-modeset
/lib/modprobe.d/blacklist-nvidia.conf:alias nvidia off
/lib/modprobe.d/blacklist-nvidia.conf:alias nvidia-drm off
/lib/modprobe.d/blacklist-nvidia.conf:alias nvidia-modeset off
/lib/modprobe.d/nvidia-kms.conf:# This file was generated by nvidia-prime
/lib/modprobe.d/nvidia-kms.conf:options nvidia-drm modeset=1
/lib/modprobe.d/nvidia-runtimepm.conf:options nvidia "NVreg_DynamicPowerManagement=0x02"

There are no nvidia kernel modules installed, how did you install the driver?

Thanks for the answer !

I installed it with Linux Mint Driver Manager

Also tried NVIDIA official script (NVIDIA-Linux-x86_64-465.27.run)

Tried ton install latest version through driver manager, without more result.

Please post the output of
dkms status

Here is the ouput :
nvidia/545.23.06: added

Please reinstall the kernel headers by running
sudo apt install --reinstall linux-headers-$(uname -r)
Afterwards, post any errors and the output of
dkms status

When I run the command, I get the following error :

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package linux-headers-6.1.0
E: Couldn't find any package by glob 'linux-headers-6.1.0'

For information, I used that kernel : GitHub - johan12345/linux: Linux kernel source tree, with patches for https://gitlab.freedesktop.org/drm/intel/-/issues/5531 applied because it had a required patch for my computer, I don’t know if this can be related.

Tried Install linux-headers on debian unable to locate package - Stack Overflow first answer, but same error

This results from the custom built kernel. You’ll have to create a symlink in /lib/modules/$(uname -r)/build to the kernel source directory where you built that kernel.

Oooops, I deleted the kernel’s built folder to make place :/
I rebuilt the kernel in the same folder, so the broken symlink is now fixed, now I can do $ cd /lib/modules/$(uname -r)/build and it works, showing the files and folders of the kernel (arch, block, built-in.a, etc.)
I rebooted my computer and relaunched the sudo apt install --reinstall linux-headers-$(uname -r) command, but same result.
Thanks again for your help.

Please run
sudo dkms install nvidia/545.23.06
post any errors displayed and the output of
dkms status

First command result’s : Module nvidia/545.23.06 already installed on kernel 6.1.0+ (x86_64).
dkms status result’s : nvidia/545.23.06, 6.1.0+, x86_64: installed

The nvidia driver is installed and should be working (after a reboot). If not, please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Right ! Did the problem got solved by fixing the symlinks ?- (to put it as solution answer)

Yes. The reboot afterwards then triggered dkms to build/install the nvidia driver.

Thanks again for taking time to help :D

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.