NVIDIA 340.96 RedHat 6.8 xorg running at 100% cpu

After the update to RedHat 6.8, when using graphical programs in X the CPU will drive up to 100% utilization with the NVIDIA 340.96 drivers installed. The new version of xorg-x11-server is 1.17 updated from 1.15. I believe they have incorporated the glamor package and possibly other updates into the new X server. Does anyone know why the CPU might be ramping up to 100% during opening or closing of windows? It can also cause the screen to white out in those windows for a few seconds until the system catches up. Thus far the only solution I have found is to downgrade all of xorg and exclude it in the yum.conf. Is this problem with the NVIDIA proprietary driver or something new in xorg?

Already covered here: https://devtalk.nvidia.com/default/topic/938213/100-cpu-usage-under-centos-6-8-nvidia-364-19-gtx-660-idle-desktop-no-composite/

Please upgrade to 367.27 - they also have this bug, but it only appears once a week at most.

I’ve no idea what causes this bug - most likely some unexpected interaction between X.org and NVIDIA drivers. By themselves these two things work just fine. Very few people run this combo, and this distro, so NVIDIA has no incentive to investigate it.

I would upgrade to 367, but quite a few of the cards I have to support are NVS300 and are only supported under the 340 version.

If you know how to trigger this bug at will, then I suspect NVIDIA will (try to) resolve it. Otherwise, no luck.

So far I haven’t found a surefire way to trigger it.

Longshot, but have you tried configuring __GL_YIELD=USLEEP?

It needs to be configured as an environment variable before the driver is loaded.

http://us.download.nvidia.com/XFree86/FreeBSD-x86/310.40/README/openglenvvariables.html

Normally I don’t run any OpenGL applications - this variable is meaningless.

The reply was for the OP, who almost certainly is using OpenGL. I’ve no idea - nor care - whether you are using OpenGL or not. Although if you’re using X.org, are you really sure you’re not using any OpenGL extensions?

While normally I don’t care when people are throwing baseless accusations and talking shlt that’s not the case now.

I can completely disable GLX support (read OpenGL support for X.org using the NVIDIA drivers) while running X.org and the server will still exhibit this bug sooner or later.

Dude, get a grip! Who made you the forum ahole?

You, sir.

You appeared out of nowhere and started talking shlt.

It seems to me that I’ve experienced this issue on Ubuntu MATE 16.04 64-bit with nvidia 340.96 driver and X.org 1.18. I had to uninstall that driver and go back to nouveau.

Here is an easy way to triger the high CPU usage:

  • In LibreOffice 5 open a text document of 10+ pages filled with text of various formatting.
  • Open print dialog (Ctrl + P).
  • Try to change print range in the Pages field.